CVE-2005-0467

Multiple integer overflows in the (1) sftp_pkt_getstring and (2) fxp_readdir_recv functions in the PSFTP and PSCP clients for PuTTY 0.56, and possibly earlier versions, allow remote malicious web sites to execute arbitrary code via SFTP responses that corrupt the heap after insufficient memory has been allocated.

Published : 2005-02-21 05:00 Updated : 2017-07-11 01:32

7.5
CVSS Score More info
Score 7.5 / 10
7.5
Vendor Product Version URI
Putty Putty 0.56 cpe:/a:putty:putty:0.56
  1. Putty (1) Search CVE
    1. Putty (1) Search CVE
      1. 0.56

CWE

There is no CWE for this CVE.

History of changes

Date Event
2017-07-11 14:53
2005-02-21 05:00

New CVE