CVE-2007-0988

The zend_hash_init function in PHP 5 before 5.2.1 and PHP 4 before 4.4.5, when running on a 64-bit platform, allows context-dependent attackers to cause a denial of service (infinite loop) by unserializing certain integer expressions, which only cause 32-bit arguments to be used after the check for a negative value, as demonstrated by an "a:2147483649:{" argument.

Published : 2007-02-20 17:28 Updated : 2019-10-09 22:52

4.3
CVSS Score More info
Score 4.3 / 10
4.3
Vendor Product Version URI
Canonical Ubuntu Linux 5.10 cpe:/o:canonical:ubuntu_linux:5.10
Canonical Ubuntu Linux 6.06 cpe:/o:canonical:ubuntu_linux:6.06::~~lts~~~
Canonical Ubuntu Linux 6.10 cpe:/o:canonical:ubuntu_linux:6.10
Php Php 4.0.0 cpe:/a:php:php:4.0.0
Php Php 4.0.1 cpe:/a:php:php:4.0.1
Php Php 4.0.1 cpe:/a:php:php:4.0.1:-
Php Php 4.0.1 cpe:/a:php:php:4.0.1:rc
Php Php 4.0.1 cpe:/a:php:php:4.0.1:rc2
Php Php 4.0.2 cpe:/a:php:php:4.0.2
Php Php 4.0.2 cpe:/a:php:php:4.0.2:rc1
Php Php 4.0.3 cpe:/a:php:php:4.0.3
Php Php 4.0.3 cpe:/a:php:php:4.0.3:rc1
Php Php 4.0.3 cpe:/a:php:php:4.0.3:rc2
Php Php 4.0.4 cpe:/a:php:php:4.0.4
Php Php 4.0.4 cpe:/a:php:php:4.0.4:-
Php Php 4.0.4 cpe:/a:php:php:4.0.4:rc1
Php Php 4.0.4 cpe:/a:php:php:4.0.4:rc2
Php Php 4.0.4 cpe:/a:php:php:4.0.4:rc3
Php Php 4.0.4 cpe:/a:php:php:4.0.4:rc4
Php Php 4.0.4 cpe:/a:php:php:4.0.4:rc5
Php Php 4.0.4 cpe:/a:php:php:4.0.4:rc6
Php Php 4.0.5 cpe:/a:php:php:4.0.5
Php Php 4.0.5 cpe:/a:php:php:4.0.5:-
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc1
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc2
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc3
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc4
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc5
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc6
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc7
Php Php 4.0.5 cpe:/a:php:php:4.0.5:rc8
Php Php 4.0.6 cpe:/a:php:php:4.0.6
Php Php 4.0.6 cpe:/a:php:php:4.0.6:-
Php Php 4.0.6 cpe:/a:php:php:4.0.6:rc1
Php Php 4.0.6 cpe:/a:php:php:4.0.6:rc2
Php Php 4.0.6 cpe:/a:php:php:4.0.6:rc3
Php Php 4.0.6 cpe:/a:php:php:4.0.6:rc4
Php Php 4.0.7 cpe:/a:php:php:4.0.7
Php Php 4.0.7 cpe:/a:php:php:4.0.7:-
Php Php 4.0.7 cpe:/a:php:php:4.0.7:rc1
Php Php 4.0.7 cpe:/a:php:php:4.0.7:rc2
Php Php 4.0.7 cpe:/a:php:php:4.0.7:rc3
Php Php 4.1.0 cpe:/a:php:php:4.1.0
Php Php 4.1.0 cpe:/a:php:php:4.1.0:-
Php Php 4.1.0 cpe:/a:php:php:4.1.0:rc1
Php Php 4.1.0 cpe:/a:php:php:4.1.0:rc2
Php Php 4.1.0 cpe:/a:php:php:4.1.0:rc3
Php Php 4.1.0 cpe:/a:php:php:4.1.0:rc4
Php Php 4.1.0 cpe:/a:php:php:4.1.0:rc5
Php Php 4.1.1 cpe:/a:php:php:4.1.1
Php Php 4.1.2 cpe:/a:php:php:4.1.2
Php Php 4.1.3 cpe:/a:php:php:4.1.3
Php Php 4.2 cpe:/a:php:php:4.2
Php Php 4.2.0 cpe:/a:php:php:4.2.0
Php Php 4.2.0 cpe:/a:php:php:4.2.0:-
Php Php 4.2.0 cpe:/a:php:php:4.2.0:rc1
Php Php 4.2.0 cpe:/a:php:php:4.2.0:rc2
Php Php 4.2.0 cpe:/a:php:php:4.2.0:rc3
Php Php 4.2.0 cpe:/a:php:php:4.2.0:rc4
Php Php 4.2.1 cpe:/a:php:php:4.2.1
Php Php 4.2.1 cpe:/a:php:php:4.2.1:-
Php Php 4.2.1 cpe:/a:php:php:4.2.1:rc1
Php Php 4.2.1 cpe:/a:php:php:4.2.1:rc2
Php Php 4.2.2 cpe:/a:php:php:4.2.2
Php Php 4.2.3 cpe:/a:php:php:4.2.3
Php Php 4.2.3 cpe:/a:php:php:4.2.3:-
Php Php 4.2.3 cpe:/a:php:php:4.2.3:rc1
Php Php 4.2.3 cpe:/a:php:php:4.2.3:rc2
Php Php 4.2.4 cpe:/a:php:php:4.2.4
Php Php 4.3 cpe:/a:php:php:4.3
Php Php 4.3.0 cpe:/a:php:php:4.3.0
Php Php 4.3.0 cpe:/a:php:php:4.3.0:-
Php Php 4.3.0 cpe:/a:php:php:4.3.0:alpha1
Php Php 4.3.0 cpe:/a:php:php:4.3.0:alpha2
Php Php 4.3.0 cpe:/a:php:php:4.3.0:alpha3
Php Php 4.3.0 cpe:/a:php:php:4.3.0:dev
Php Php 4.3.0 cpe:/a:php:php:4.3.0:pre1
Php Php 4.3.0 cpe:/a:php:php:4.3.0:pre2
Php Php 4.3.0 cpe:/a:php:php:4.3.0:rc1
Php Php 4.3.0 cpe:/a:php:php:4.3.0:rc2
Php Php 4.3.0 cpe:/a:php:php:4.3.0:rc3
Php Php 4.3.0 cpe:/a:php:php:4.3.0:rc4
Php Php 4.3.1 cpe:/a:php:php:4.3.1
Php Php 4.3.2 cpe:/a:php:php:4.3.2
Php Php 4.3.2 cpe:/a:php:php:4.3.2:-
Php Php 4.3.2 cpe:/a:php:php:4.3.2:rc1
Php Php 4.3.2 cpe:/a:php:php:4.3.2:rc2
Php Php 4.3.2 cpe:/a:php:php:4.3.2:rc3
Php Php 4.3.2 cpe:/a:php:php:4.3.2:rc4
Php Php 4.3.3 cpe:/a:php:php:4.3.3
Php Php 4.3.3 cpe:/a:php:php:4.3.3:-
Php Php 4.3.3 cpe:/a:php:php:4.3.3:rc1
Php Php 4.3.3 cpe:/a:php:php:4.3.3:rc2
Php Php 4.3.3 cpe:/a:php:php:4.3.3:rc3
Php Php 4.3.3 cpe:/a:php:php:4.3.3:rc4
Php Php 4.3.4 cpe:/a:php:php:4.3.4
Php Php 4.3.4 cpe:/a:php:php:4.3.4:-
Php Php 4.3.4 cpe:/a:php:php:4.3.4:rc1
Php Php 4.3.4 cpe:/a:php:php:4.3.4:rc2
Php Php 4.3.4 cpe:/a:php:php:4.3.4:rc3
Php Php 4.3.5 cpe:/a:php:php:4.3.5
Php Php 4.3.5 cpe:/a:php:php:4.3.5:-
Php Php 4.3.5 cpe:/a:php:php:4.3.5:rc1
Php Php 4.3.5 cpe:/a:php:php:4.3.5:rc2
Php Php 4.3.5 cpe:/a:php:php:4.3.5:rc3
Php Php 4.3.5 cpe:/a:php:php:4.3.5:rc4
Php Php 4.3.6 cpe:/a:php:php:4.3.6
Php Php 4.3.6 cpe:/a:php:php:4.3.6:-
Php Php 4.3.6 cpe:/a:php:php:4.3.6:rc1
Php Php 4.3.6 cpe:/a:php:php:4.3.6:rc2
Php Php 4.3.6 cpe:/a:php:php:4.3.6:rc3
Php Php 4.3.7 cpe:/a:php:php:4.3.7
Php Php 4.3.7 cpe:/a:php:php:4.3.7:-
Php Php 4.3.7 cpe:/a:php:php:4.3.7:rc1
Php Php 4.3.8 cpe:/a:php:php:4.3.8
Php Php 4.3.9 cpe:/a:php:php:4.3.9
Php Php 4.3.9 cpe:/a:php:php:4.3.9:rc1
Php Php 4.3.9 cpe:/a:php:php:4.3.9:rc2
Php Php 4.3.9 cpe:/a:php:php:4.3.9:rc3
Php Php 4.3.10 cpe:/a:php:php:4.3.10
Php Php 4.3.10 cpe:/a:php:php:4.3.10:-
Php Php 4.3.10 cpe:/a:php:php:4.3.10:rc1
Php Php 4.3.10 cpe:/a:php:php:4.3.10:rc2
Php Php 4.3.11 cpe:/a:php:php:4.3.11
Php Php 4.3.11 cpe:/a:php:php:4.3.11:-
Php Php 4.3.11 cpe:/a:php:php:4.3.11:rc1
Php Php 4.3.11 cpe:/a:php:php:4.3.11:rc2
Php Php 4.4.0 cpe:/a:php:php:4.4.0
Php Php 4.4.0 cpe:/a:php:php:4.4.0:-
Php Php 4.4.0 cpe:/a:php:php:4.4.0:rc1
Php Php 4.4.0 cpe:/a:php:php:4.4.0:rc2
Php Php 4.4.1 cpe:/a:php:php:4.4.1
Php Php 4.4.1 cpe:/a:php:php:4.4.1:-
Php Php 4.4.1 cpe:/a:php:php:4.4.1:rc1
Php Php 4.4.2 cpe:/a:php:php:4.4.2
Php Php 4.4.2 cpe:/a:php:php:4.4.2:-
Php Php 4.4.2 cpe:/a:php:php:4.4.2:rc1
Php Php 4.4.2 cpe:/a:php:php:4.4.2:rc2
Php Php 4.4.3 cpe:/a:php:php:4.4.3
Php Php 4.4.3 cpe:/a:php:php:4.4.3:-
Php Php 4.4.3 cpe:/a:php:php:4.4.3:rc1
Php Php 4.4.3 cpe:/a:php:php:4.4.3:rc2
Php Php 4.4.4 cpe:/a:php:php:4.4.4
Php Php 4.4.4 cpe:/a:php:php:4.4.4:-
Php Php 4.4.4 cpe:/a:php:php:4.4.4:rc1
Php Php 5.0.0 cpe:/a:php:php:5.0.0
Php Php 5.0.0 cpe:/a:php:php:5.0.0:-
Php Php 5.0.0 cpe:/a:php:php:5.0.0:beta1
Php Php 5.0.0 cpe:/a:php:php:5.0.0:beta2
Php Php 5.0.0 cpe:/a:php:php:5.0.0:beta3
Php Php 5.0.0 cpe:/a:php:php:5.0.0:beta4
Php Php 5.0.0 cpe:/a:php:php:5.0.0:rc1
Php Php 5.0.0 cpe:/a:php:php:5.0.0:rc2
Php Php 5.0.0 cpe:/a:php:php:5.0.0:rc3
Php Php 5.0.1 cpe:/a:php:php:5.0.1
Php Php 5.0.1 cpe:/a:php:php:5.0.1:-
Php Php 5.0.1 cpe:/a:php:php:5.0.1:beta1
Php Php 5.0.1 cpe:/a:php:php:5.0.1:rc1
Php Php 5.0.1 cpe:/a:php:php:5.0.1:rc2
Php Php 5.0.2 cpe:/a:php:php:5.0.2
Php Php 5.0.2 cpe:/a:php:php:5.0.2:-
Php Php 5.0.2 cpe:/a:php:php:5.0.2:rc1
Php Php 5.0.3 cpe:/a:php:php:5.0.3
Php Php 5.0.3 cpe:/a:php:php:5.0.3:-
Php Php 5.0.3 cpe:/a:php:php:5.0.3:rc1
Php Php 5.0.3 cpe:/a:php:php:5.0.3:rc2
Php Php 5.0.4 cpe:/a:php:php:5.0.4
Php Php 5.0.4 cpe:/a:php:php:5.0.4:-
Php Php 5.0.4 cpe:/a:php:php:5.0.4:rc1
Php Php 5.0.4 cpe:/a:php:php:5.0.4:rc2
Php Php 5.0.5 cpe:/a:php:php:5.0.5
Php Php 5.0.5 cpe:/a:php:php:5.0.5:-
Php Php 5.0.5 cpe:/a:php:php:5.0.5:rc1
Php Php 5.0.5 cpe:/a:php:php:5.0.5:rc2
Php Php 5.1 cpe:/a:php:php:5.1
Php Php 5.1.0 cpe:/a:php:php:5.1.0
Php Php 5.1.0 cpe:/a:php:php:5.1.0:-
Php Php 5.1.0 cpe:/a:php:php:5.1.0:beta1
Php Php 5.1.0 cpe:/a:php:php:5.1.0:beta2
Php Php 5.1.0 cpe:/a:php:php:5.1.0:beta3
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc1
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc2
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc2-pre
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc3
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc4
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc5
Php Php 5.1.0 cpe:/a:php:php:5.1.0:rc6
Php Php 5.1.1 cpe:/a:php:php:5.1.1
Php Php 5.1.2 cpe:/a:php:php:5.1.2
Php Php 5.1.2 cpe:/a:php:php:5.1.2:-
Php Php 5.1.2 cpe:/a:php:php:5.1.2:rc1
Php Php 5.1.2 cpe:/a:php:php:5.1.2:rc2
Php Php 5.1.3 cpe:/a:php:php:5.1.3
Php Php 5.1.3 cpe:/a:php:php:5.1.3:rc1
Php Php 5.1.3 cpe:/a:php:php:5.1.3:rc2
Php Php 5.1.3 cpe:/a:php:php:5.1.3:rc3
Php Php 5.1.4 cpe:/a:php:php:5.1.4
Php Php 5.1.5 cpe:/a:php:php:5.1.5
Php Php 5.1.5 cpe:/a:php:php:5.1.5:-
Php Php 5.1.5 cpe:/a:php:php:5.1.5:rc1
Php Php 5.1.6 cpe:/a:php:php:5.1.6
Php Php 5.2.0 cpe:/a:php:php:5.2.0
Php Php 5.2.0 cpe:/a:php:php:5.2.0:rc1
Php Php 5.2.0 cpe:/a:php:php:5.2.0:rc2
Php Php 5.2.0 cpe:/a:php:php:5.2.0:rc3
Php Php 5.2.0 cpe:/a:php:php:5.2.0:rc4
Php Php 5.2.0 cpe:/a:php:php:5.2.0:rc5
Php Php 5.2.0 cpe:/a:php:php:5.2.0:rc6
Php Php 4.0 cpe:/a:php:php:4.0:beta1
Php Php 4.0 cpe:/a:php:php:4.0:beta2
Php Php 4.0 cpe:/a:php:php:4.0:beta3
Php Php 4.0 cpe:/a:php:php:4.0:beta4
Php Php 4.0 cpe:/a:php:php:4.0
Php Php 4.0 cpe:/a:php:php:4.0:beta_4_patch1
Php Php 4.0 cpe:/a:php:php:4.0:rc1
Php Php 4.0 cpe:/a:php:php:4.0:rc2
  1. Php (1) Search CVE
    1. Php (52) Search CVE
      1. 4.0.0
      2. 4.0.1
      3. 4.0.2
      4. 4.0.3
      5. 4.0.4
      6. 4.0.5
      7. 4.0.6
      8. 4.0.7
      9. 4.1.0
      10. 4.1.1
      11. 4.1.2
      12. 4.1.3
      13. 4.2
      14. 4.2.0
      15. 4.2.1
      16. 4.2.2
      17. 4.2.3
      18. 4.2.4
      19. 4.3
      20. 4.3.0
      21. 4.3.1
      22. 4.3.2
      23. 4.3.3
      24. 4.3.4
      25. 4.3.5
      26. 4.3.6
      27. 4.3.7
      28. 4.3.8
      29. 4.3.9
      30. 4.3.10
      31. 4.3.11
      32. 4.4.0
      33. 4.4.1
      34. 4.4.2
      35. 4.4.3
      36. 4.4.4
      37. 5.0.0
      38. 5.0.1
      39. 5.0.2
      40. 5.0.3
      41. 5.0.4
      42. 5.0.5
      43. 5.1
      44. 5.1.0
      45. 5.1.1
      46. 5.1.2
      47. 5.1.3
      48. 5.1.4
      49. 5.1.5
      50. 5.1.6
      51. 5.2.0
      52. 4.0
  2. Canonical (1) Search CVE
    1. Ubuntu Linux (3) Search CVE
      1. 5.10
      2. 6.06
      3. 6.10

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

References

Source Link
SGI ftp://patches.sgi.com/support/free/security/advisories/20070201-01-P.asc
SUSE http://www.novell.com/linux/security/advisories/2007_32_php.html
TRUSTIX http://www.trustix.org/errata/2007/0009/
DEBIAN http://www.us.debian.org/security/2007/dsa-1264
VUPEN http://www.vupen.com/english/advisories/2007/1991
CONFIRM https://issues.rpath.com/browse/RPL-1088
HP http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01086137
UBUNTU http://www.ubuntu.com/usn/usn-424-1
MISC http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=228858
REDHAT http://www.redhat.com/support/errata/RHSA-2007-0082.html
MANDRIVA http://www.mandriva.com/security/advisories?name=MDKSA-2007:048
GENTOO http://security.gentoo.org/glsa/glsa-200703-21.xml
MISC http://www.php-security.org/MOPB/MOPB-05-2007.html
MISC http://www.php.net/releases/5_2_1.php
OPENPKG http://www.openpkg.com/security/advisories/OpenPKG-SA-2007.010.html
VUPEN http://www.vupen.com/english/advisories/2007/2374
REDHAT http://rhn.redhat.com/errata/RHSA-2007-0089.html
CONFIRM http://support.avaya.com/elmodocs2/security/ASA-2007-101.htm
SREASON http://securityreason.com/securityalert/2315
CONFIRM http://support.avaya.com/elmodocs2/security/ASA-2007-136.htm
SECTRACK http://www.securitytracker.com/id?1017671
REDHAT http://www.redhat.com/support/errata/RHSA-2007-0076.html
REDHAT http://www.redhat.com/support/errata/RHSA-2007-0088.html
UBUNTU http://www.ubuntu.com/usn/usn-424-2
REDHAT http://www.redhat.com/support/errata/RHSA-2007-0081.html
HP http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01056506
XF https://exchange.xforce.ibmcloud.com/vulnerabilities/32709
BUGTRAQ http://www.securityfocus.com/archive/1/461462/100/0/threaded

History of changes

Date Event
2019-10-09 22:52
2018-10-19 18:05
2018-10-16 16:35
2017-07-31 20:48
2007-02-20 17:28

New CVE