CVE-2008-2829

php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.

Published : 2008-06-23 20:41 Updated : 2019-10-09 22:55

5.0
CVSS Score More info
Score 5.0 / 10
5.0
Vendor Product Version URI
Php Php 4.4.9 cpe:/a:php:php:4.4.9
Canonical Ubuntu Linux 6.06 cpe:/o:canonical:ubuntu_linux:6.06::~~lts~~~
Canonical Ubuntu Linux 7.04 cpe:/o:canonical:ubuntu_linux:7.04
Canonical Ubuntu Linux 7.10 cpe:/o:canonical:ubuntu_linux:7.10
Canonical Ubuntu Linux 8.04 cpe:/o:canonical:ubuntu_linux:8.04::~~lts~~~
Php Php 5.2.6 cpe:/a:php:php:5.2.6
Php Php 5.2.5 cpe:/a:php:php:5.2.5
  1. Php (1) Search CVE
    1. Php (3) Search CVE
      1. 4.4.9
      2. 5.2.6
      3. 5.2.5
  2. Canonical (1) Search CVE
    1. Ubuntu Linux (4) Search CVE
      1. 6.06
      2. 7.04
      3. 7.10
      4. 8.04

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

History of changes

Date Event
2019-10-09 22:55
2018-11-01 15:09
2018-10-11 20:44
2017-08-08 05:42
2008-06-23 20:41

New CVE