CVE-2012-6151

Net-SNMP 5.7.1 and earlier, when AgentX is registering to handle a MIB and processing GETNEXT requests, allows remote attackers to cause a denial of service (crash or infinite loop, CPU consumption, and hang) by causing the AgentX subagent to timeout.

Published : 2013-12-13 18:55 Updated : 2017-08-29 01:32

4.3
CVSS Score More info
Score 4.3 / 10
4.3
Vendor Product Version URI
Apple Mac Os X 10.11.0 cpe:/o:apple:mac_os_x:10.11.0
Net-snmp Net-snmp 5.0.6 cpe:/a:net-snmp:net-snmp:5.0.6
Net-snmp Net-snmp 5.7 cpe:/a:net-snmp:net-snmp:5.7
Net-snmp Net-snmp 5.0.5 cpe:/a:net-snmp:net-snmp:5.0.5
Net-snmp Net-snmp 5.6 cpe:/a:net-snmp:net-snmp:5.6
Net-snmp Net-snmp 5.0.4 cpe:/a:net-snmp:net-snmp:5.0.4
Net-snmp Net-snmp 5.5 cpe:/a:net-snmp:net-snmp:5.5
Net-snmp Net-snmp 5.1.2 cpe:/a:net-snmp:net-snmp:5.1.2
Net-snmp Net-snmp 5.0.3 cpe:/a:net-snmp:net-snmp:5.0.3
Net-snmp Net-snmp 5.4 cpe:/a:net-snmp:net-snmp:5.4
Net-snmp Net-snmp 5.0.2 cpe:/a:net-snmp:net-snmp:5.0.2
Net-snmp Net-snmp 5.3.0.1 cpe:/a:net-snmp:net-snmp:5.3.0.1
Net-snmp Net-snmp 5.3 cpe:/a:net-snmp:net-snmp:5.3
Net-snmp Net-snmp 5.0.1 cpe:/a:net-snmp:net-snmp:5.0.1
Net-snmp Net-snmp 5.2 cpe:/a:net-snmp:net-snmp:5.2
Net-snmp Net-snmp 5.1 cpe:/a:net-snmp:net-snmp:5.1
Net-snmp Net-snmp 5.0 cpe:/a:net-snmp:net-snmp:5.0
Net-snmp Net-snmp 5.0.9 cpe:/a:net-snmp:net-snmp:5.0.9
Canonical Ubuntu Linux 13.10 cpe:/o:canonical:ubuntu_linux:13.10
Net-snmp Net-snmp 5.7.1 cpe:/a:net-snmp:net-snmp:5.7.1
Net-snmp Net-snmp 5.0.8 cpe:/a:net-snmp:net-snmp:5.0.8
Net-snmp Net-snmp 5.0.7 cpe:/a:net-snmp:net-snmp:5.0.7
Canonical Ubuntu Linux 12.04 cpe:/o:canonical:ubuntu_linux:12.04::~~lts~~~
Canonical Ubuntu Linux 10.04 cpe:/o:canonical:ubuntu_linux:10.04::~~lts~~~
Canonical Ubuntu Linux 12.10 cpe:/o:canonical:ubuntu_linux:12.10
  1. Canonical (1) Search CVE
    1. Ubuntu Linux (4) Search CVE
      1. 13.10
      2. 12.04
      3. 10.04
      4. 12.10
  2. Apple (1) Search CVE
    1. Mac Os X (1) Search CVE
      1. 10.11.0
  3. Net-snmp (1) Search CVE
    1. Net-snmp (20) Search CVE
      1. 5.0.6
      2. 5.7
      3. 5.0.5
      4. 5.6
      5. 5.0.4
      6. 5.5
      7. 5.1.2
      8. 5.0.3
      9. 5.4
      10. 5.0.2
      11. 5.3.0.1
      12. 5.3
      13. 5.0.1
      14. 5.2
      15. 5.1
      16. 5.0
      17. 5.0.9
      18. 5.7.1
      19. 5.0.8
      20. 5.0.7

CWE

ID Name Description Links
CWE-399 Resource Management Errors Weaknesses in this category are related to improper management of system resources. CVE

History of changes

Date Event
2017-08-29 06:20
2013-12-13 18:55

New CVE