CVE-2014-9709

The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

Published : 2015-03-30 10:59 Updated : 2019-10-09 23:12

5.0
CVSS Score More info
Score 5.0 / 10
5.0
Vendor Product Version URI
Php Php 5.5.0 cpe:/a:php:php:5.5.0
Php Php 5.5.0 cpe:/a:php:php:5.5.0:-
Php Php 5.5.0 cpe:/a:php:php:5.5.0:alpha1
Php Php 5.5.0 cpe:/a:php:php:5.5.0:alpha2
Php Php 5.5.0 cpe:/a:php:php:5.5.0:alpha3
Php Php 5.5.0 cpe:/a:php:php:5.5.0:alpha4
Php Php 5.5.0 cpe:/a:php:php:5.5.0:alpha5
Php Php 5.5.0 cpe:/a:php:php:5.5.0:alpha6
Php Php 5.5.0 cpe:/a:php:php:5.5.0:beta1
Php Php 5.5.0 cpe:/a:php:php:5.5.0:beta2
Php Php 5.5.0 cpe:/a:php:php:5.5.0:beta3
Php Php 5.5.0 cpe:/a:php:php:5.5.0:beta4
Php Php 5.5.0 cpe:/a:php:php:5.5.0:rc1
Php Php 5.5.0 cpe:/a:php:php:5.5.0:rc2
Php Php 5.5.0 cpe:/a:php:php:5.5.0:rc3
Php Php 5.5.1 cpe:/a:php:php:5.5.1
Php Php 5.5.2 cpe:/a:php:php:5.5.2
Php Php 5.5.2 cpe:/a:php:php:5.5.2:-
Php Php 5.5.2 cpe:/a:php:php:5.5.2:rc1
Php Php 5.5.3 cpe:/a:php:php:5.5.3
Php Php 5.5.4 cpe:/a:php:php:5.5.4
Php Php 5.5.4 cpe:/a:php:php:5.5.4:-
Php Php 5.5.4 cpe:/a:php:php:5.5.4:rc1
Php Php 5.5.5 cpe:/a:php:php:5.5.5
Php Php 5.5.5 cpe:/a:php:php:5.5.5:-
Php Php 5.5.5 cpe:/a:php:php:5.5.5:rc1
Php Php 5.5.6 cpe:/a:php:php:5.5.6
Php Php 5.5.6 cpe:/a:php:php:5.5.6:-
Php Php 5.5.6 cpe:/a:php:php:5.5.6:rc1
Php Php 5.5.7 cpe:/a:php:php:5.5.7
Php Php 5.5.7 cpe:/a:php:php:5.5.7:-
Php Php 5.5.7 cpe:/a:php:php:5.5.7:rc1
Php Php 5.5.8 cpe:/a:php:php:5.5.8
Php Php 5.5.8 cpe:/a:php:php:5.5.8:-
Php Php 5.5.8 cpe:/a:php:php:5.5.8:rc1
Php Php 5.5.9 cpe:/a:php:php:5.5.9
Php Php 5.5.9 cpe:/a:php:php:5.5.9:-
Php Php 5.5.9 cpe:/a:php:php:5.5.9:rc1
Php Php 5.5.10 cpe:/a:php:php:5.5.10
Php Php 5.5.10 cpe:/a:php:php:5.5.10:-
Php Php 5.5.10 cpe:/a:php:php:5.5.10:rc1
Php Php 5.5.11 cpe:/a:php:php:5.5.11
Php Php 5.5.11 cpe:/a:php:php:5.5.11:-
Php Php 5.5.11 cpe:/a:php:php:5.5.11:rc1
Php Php 5.5.12 cpe:/a:php:php:5.5.12
Php Php 5.5.12 cpe:/a:php:php:5.5.12:-
Php Php 5.5.12 cpe:/a:php:php:5.5.12:rc1
Php Php 5.5.13 cpe:/a:php:php:5.5.13
Php Php 5.5.13 cpe:/a:php:php:5.5.13:-
Php Php 5.5.13 cpe:/a:php:php:5.5.13:rc1
Php Php 5.5.14 cpe:/a:php:php:5.5.14
Php Php 5.5.14 cpe:/a:php:php:5.5.14:-
Php Php 5.5.14 cpe:/a:php:php:5.5.14:rc1
Php Php 5.5.15 cpe:/a:php:php:5.5.15
Php Php 5.5.15 cpe:/a:php:php:5.5.15:-
Php Php 5.5.15 cpe:/a:php:php:5.5.15:rc1
Php Php 5.5.16 cpe:/a:php:php:5.5.16
Php Php 5.5.16 cpe:/a:php:php:5.5.16:-
Php Php 5.5.16 cpe:/a:php:php:5.5.16:rc1
Php Php 5.5.17 cpe:/a:php:php:5.5.17
Php Php 5.5.17 cpe:/a:php:php:5.5.17:-
Php Php 5.5.17 cpe:/a:php:php:5.5.17:rc1
Php Php 5.5.18 cpe:/a:php:php:5.5.18
Php Php 5.5.18 cpe:/a:php:php:5.5.18:-
Php Php 5.5.18 cpe:/a:php:php:5.5.18:rc1
Php Php 5.5.19 cpe:/a:php:php:5.5.19
Php Php 5.5.19 cpe:/a:php:php:5.5.19:-
Php Php 5.5.19 cpe:/a:php:php:5.5.19:rc1
Php Php 5.5.20 cpe:/a:php:php:5.5.20
Php Php 5.5.20 cpe:/a:php:php:5.5.20:-
Php Php 5.5.20 cpe:/a:php:php:5.5.20:rc1
Php Php 5.6.0 cpe:/a:php:php:5.6.0
Php Php 5.6.0 cpe:/a:php:php:5.6.0:-
Php Php 5.6.0 cpe:/a:php:php:5.6.0:alpha1
Php Php 5.6.0 cpe:/a:php:php:5.6.0:alpha2
Php Php 5.6.0 cpe:/a:php:php:5.6.0:alpha3
Php Php 5.6.0 cpe:/a:php:php:5.6.0:alpha4
Php Php 5.6.0 cpe:/a:php:php:5.6.0:alpha5
Php Php 5.6.0 cpe:/a:php:php:5.6.0:beta1
Php Php 5.6.0 cpe:/a:php:php:5.6.0:beta2
Php Php 5.6.0 cpe:/a:php:php:5.6.0:beta3
Php Php 5.6.0 cpe:/a:php:php:5.6.0:beta4
Php Php 5.6.0 cpe:/a:php:php:5.6.0:rc1
Php Php 5.6.0 cpe:/a:php:php:5.6.0:rc2
Php Php 5.6.0 cpe:/a:php:php:5.6.0:rc3
Php Php 5.6.0 cpe:/a:php:php:5.6.0:rc4
Php Php 5.6.1 cpe:/a:php:php:5.6.1
Php Php 5.6.1 cpe:/a:php:php:5.6.1:-
Php Php 5.6.1 cpe:/a:php:php:5.6.1:rc1
Php Php 5.6.2 cpe:/a:php:php:5.6.2
Php Php 5.6.3 cpe:/a:php:php:5.6.3
Php Php 5.6.3 cpe:/a:php:php:5.6.3:-
Php Php 5.6.3 cpe:/a:php:php:5.6.3:rc1
Php Php 5.6.4 cpe:/a:php:php:5.6.4
Php Php 5.6.4 cpe:/a:php:php:5.6.4:-
Php Php 5.6.4 cpe:/a:php:php:5.6.4:rc1
Libgd Libgd 2.1.1 cpe:/a:libgd:libgd:2.1.1
Opensuse Opensuse 13.1 cpe:/o:opensuse:opensuse:13.1
Opensuse Opensuse 13.2 cpe:/o:opensuse:opensuse:13.2
Canonical Ubuntu Linux 12.04 cpe:/o:canonical:ubuntu_linux:12.04::~~lts~~~
Canonical Ubuntu Linux 14.04 cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~
Canonical Ubuntu Linux 15.10 cpe:/o:canonical:ubuntu_linux:15.10
Canonical Ubuntu Linux 16.04 cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~
Debian Debian Linux 7.0 cpe:/o:debian:debian_linux:7.0
Debian Debian Linux 8.0 cpe:/o:debian:debian_linux:8.0
  1. Php (1) Search CVE
    1. Php (26) Search CVE
      1. 5.5.0
      2. 5.5.1
      3. 5.5.2
      4. 5.5.3
      5. 5.5.4
      6. 5.5.5
      7. 5.5.6
      8. 5.5.7
      9. 5.5.8
      10. 5.5.9
      11. 5.5.10
      12. 5.5.11
      13. 5.5.12
      14. 5.5.13
      15. 5.5.14
      16. 5.5.15
      17. 5.5.16
      18. 5.5.17
      19. 5.5.18
      20. 5.5.19
      21. 5.5.20
      22. 5.6.0
      23. 5.6.1
      24. 5.6.2
      25. 5.6.3
      26. 5.6.4
  2. Debian (1) Search CVE
    1. Debian Linux (2) Search CVE
      1. 7.0
      2. 8.0
  3. Canonical (1) Search CVE
    1. Ubuntu Linux (4) Search CVE
      1. 12.04
      2. 14.04
      3. 15.10
      4. 16.04
  4. Libgd (1) Search CVE
    1. Libgd (1) Search CVE
      1. 2.1.1
  5. Opensuse (1) Search CVE
    1. Opensuse (2) Search CVE
      1. 13.1
      2. 13.2

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

History of changes

Date Event
2019-10-09 23:12
2019-02-01 18:21
2018-10-30 16:27
2018-01-05 02:29
2015-03-30 10:59

New CVE