CVE-2015-5261

Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to read and write to arbitrary memory locations on the host via guest QXL commands related to surface creation.

Published : 2016-06-07 14:06 Updated : 2017-09-16 01:29

3.6
CVSS Score More info
Score 3.6 / 10
3.6
Vendor Product Version URI
Debian Debian Linux 8.0 cpe:/o:debian:debian_linux:8.0
Redhat Enterprise Linux Server Eus 7.1 cpe:/o:redhat:enterprise_linux_server_eus:7.1
Canonical Ubuntu Linux 14.04 cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~
Redhat Enterprise Linux Workstation 6.0 cpe:/o:redhat:enterprise_linux_workstation:6.0
Redhat Enterprise Linux Server 6.0 cpe:/o:redhat:enterprise_linux_server:6.0
Debian Debian Linux 7.0 cpe:/o:debian:debian_linux:7.0
Redhat Enterprise Linux Server Eus 6.7.z cpe:/o:redhat:enterprise_linux_server_eus:6.7.z
Redhat Enterprise Linux Server 7.0 cpe:/o:redhat:enterprise_linux_server:7.0
Spice Project Spice 0.12.5 cpe:/a:spice_project:spice:0.12.5
Redhat Enterprise Linux Hpc Node 7.0 cpe:/o:redhat:enterprise_linux_hpc_node:7.0
Redhat Enterprise Linux Hpc Node 6.0 cpe:/o:redhat:enterprise_linux_hpc_node:6.0
Redhat Enterprise Linux Workstation 7.0 cpe:/o:redhat:enterprise_linux_workstation:7.0
Redhat Enterprise Linux Desktop 6.0 cpe:/o:redhat:enterprise_linux_desktop:6.0
Redhat Enterprise Linux Desktop 7.0 cpe:/o:redhat:enterprise_linux_desktop:7.0
Redhat Enterprise Linux Hpc Node Eus 7.1 cpe:/o:redhat:enterprise_linux_hpc_node_eus:7.1
Canonical Ubuntu Linux 15.04 cpe:/o:canonical:ubuntu_linux:15.04
  1. Debian (1) Search CVE
    1. Debian Linux (2) Search CVE
      1. 8.0
      2. 7.0
  2. Redhat (6) Search CVE
    1. Enterprise Linux Hpc Node Eus (1) Search CVE
      1. 7.1
    2. Enterprise Linux Hpc Node (2) Search CVE
      1. 7.0
      2. 6.0
    3. Enterprise Linux Server Eus (2) Search CVE
      1. 7.1
      2. 6.7.z
    4. Enterprise Linux Desktop (2) Search CVE
      1. 6.0
      2. 7.0
    5. Enterprise Linux Server (2) Search CVE
      1. 6.0
      2. 7.0
    6. Enterprise Linux Workstation (2) Search CVE
      1. 6.0
      2. 7.0
  3. Spice Project (1) Search CVE
    1. Spice (1) Search CVE
      1. 0.12.5
  4. Canonical (1) Search CVE
    1. Ubuntu Linux (2) Search CVE
      1. 14.04
      2. 15.04

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

History of changes

Date Event
2017-09-16 05:28
2016-06-07 14:06

New CVE