CVE-2016-0785

Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.

Published : 2016-04-12 16:59 Updated : 2019-08-23 15:50

9.0
CVSS Score More info
Score 9.0 / 10
9.0
Vendor Product Version URI
Apache Struts 2.0.0 cpe:/a:apache:struts:2.0.0
Apache Struts 2.0.1 cpe:/a:apache:struts:2.0.1
Apache Struts 2.0.2 cpe:/a:apache:struts:2.0.2
Apache Struts 2.0.3 cpe:/a:apache:struts:2.0.3
Apache Struts 2.0.4 cpe:/a:apache:struts:2.0.4
Apache Struts 2.0.5 cpe:/a:apache:struts:2.0.5
Apache Struts 2.0.6 cpe:/a:apache:struts:2.0.6
Apache Struts 2.0.7 cpe:/a:apache:struts:2.0.7
Apache Struts 2.0.8 cpe:/a:apache:struts:2.0.8
Apache Struts 2.0.9 cpe:/a:apache:struts:2.0.9
Apache Struts 2.0.10 cpe:/a:apache:struts:2.0.10
Apache Struts 2.0.11 cpe:/a:apache:struts:2.0.11
Apache Struts 2.0.11.1 cpe:/a:apache:struts:2.0.11.1
Apache Struts 2.0.11.2 cpe:/a:apache:struts:2.0.11.2
Apache Struts 2.0.12 cpe:/a:apache:struts:2.0.12
Apache Struts 2.0.13 cpe:/a:apache:struts:2.0.13
Apache Struts 2.0.14 cpe:/a:apache:struts:2.0.14
Apache Struts 2.1.0 cpe:/a:apache:struts:2.1.0
Apache Struts 2.1.1 cpe:/a:apache:struts:2.1.1
Apache Struts 2.1.2 cpe:/a:apache:struts:2.1.2
Apache Struts 2.1.3 cpe:/a:apache:struts:2.1.3
Apache Struts 2.1.4 cpe:/a:apache:struts:2.1.4
Apache Struts 2.1.5 cpe:/a:apache:struts:2.1.5
Apache Struts 2.1.6 cpe:/a:apache:struts:2.1.6
Apache Struts 2.1.7 cpe:/a:apache:struts:2.1.7
Apache Struts 2.1.8 cpe:/a:apache:struts:2.1.8
Apache Struts 2.1.8.1 cpe:/a:apache:struts:2.1.8.1
Apache Struts 2.2.1 cpe:/a:apache:struts:2.2.1
Apache Struts 2.2.1.1 cpe:/a:apache:struts:2.2.1.1
Apache Struts 2.2.3 cpe:/a:apache:struts:2.2.3
Apache Struts 2.2.3.1 cpe:/a:apache:struts:2.2.3.1
Apache Struts 2.3.0 cpe:/a:apache:struts:2.3.0
Apache Struts 2.3.1 cpe:/a:apache:struts:2.3.1
Apache Struts 2.3.1.1 cpe:/a:apache:struts:2.3.1.1
Apache Struts 2.3.1.2 cpe:/a:apache:struts:2.3.1.2
Apache Struts 2.3.3 cpe:/a:apache:struts:2.3.3
Apache Struts 2.3.4 cpe:/a:apache:struts:2.3.4
Apache Struts 2.3.4.1 cpe:/a:apache:struts:2.3.4.1
Apache Struts 2.3.5 cpe:/a:apache:struts:2.3.5
Apache Struts 2.3.6 cpe:/a:apache:struts:2.3.6
Apache Struts 2.3.7 cpe:/a:apache:struts:2.3.7
Apache Struts 2.3.8 cpe:/a:apache:struts:2.3.8
Apache Struts 2.3.9 cpe:/a:apache:struts:2.3.9
Apache Struts 2.3.10 cpe:/a:apache:struts:2.3.10
Apache Struts 2.3.11 cpe:/a:apache:struts:2.3.11
Apache Struts 2.3.12 cpe:/a:apache:struts:2.3.12
Apache Struts 2.3.13 cpe:/a:apache:struts:2.3.13
Apache Struts 2.3.14 cpe:/a:apache:struts:2.3.14
Apache Struts 2.3.14.1 cpe:/a:apache:struts:2.3.14.1
Apache Struts 2.3.14.2 cpe:/a:apache:struts:2.3.14.2
Apache Struts 2.3.14.3 cpe:/a:apache:struts:2.3.14.3
Apache Struts 2.3.15 cpe:/a:apache:struts:2.3.15
Apache Struts 2.3.15.1 cpe:/a:apache:struts:2.3.15.1
Apache Struts 2.3.15.2 cpe:/a:apache:struts:2.3.15.2
Apache Struts 2.3.15.3 cpe:/a:apache:struts:2.3.15.3
Apache Struts 2.3.16 cpe:/a:apache:struts:2.3.16
Apache Struts 2.3.16.1 cpe:/a:apache:struts:2.3.16.1
Apache Struts 2.3.16.2 cpe:/a:apache:struts:2.3.16.2
Apache Struts 2.3.16.3 cpe:/a:apache:struts:2.3.16.3
Apache Struts 2.3.17 cpe:/a:apache:struts:2.3.17
Apache Struts 2.3.19 cpe:/a:apache:struts:2.3.19
Apache Struts 2.3.20 cpe:/a:apache:struts:2.3.20
Apache Struts 2.3.20.1 cpe:/a:apache:struts:2.3.20.1
Apache Struts 2.3.20.2 cpe:/a:apache:struts:2.3.20.2
Apache Struts 2.3.24 cpe:/a:apache:struts:2.3.24
Apache Struts 2.3.21 cpe:/a:apache:struts:2.3.21
Apache Struts 2.3.22 cpe:/a:apache:struts:2.3.22
Apache Struts 2.3.23 cpe:/a:apache:struts:2.3.23
Apache Struts 2.3.24.1 cpe:/a:apache:struts:2.3.24.1
  1. Apache (1) Search CVE
    1. Struts (69) Search CVE
      1. 2.0.0
      2. 2.0.1
      3. 2.0.2
      4. 2.0.3
      5. 2.0.4
      6. 2.0.5
      7. 2.0.6
      8. 2.0.7
      9. 2.0.8
      10. 2.0.9
      11. 2.0.10
      12. 2.0.11
      13. 2.0.11.1
      14. 2.0.11.2
      15. 2.0.12
      16. 2.0.13
      17. 2.0.14
      18. 2.1.0
      19. 2.1.1
      20. 2.1.2
      21. 2.1.3
      22. 2.1.4
      23. 2.1.5
      24. 2.1.6
      25. 2.1.7
      26. 2.1.8
      27. 2.1.8.1
      28. 2.2.1
      29. 2.2.1.1
      30. 2.2.3
      31. 2.2.3.1
      32. 2.3.0
      33. 2.3.1
      34. 2.3.1.1
      35. 2.3.1.2
      36. 2.3.3
      37. 2.3.4
      38. 2.3.4.1
      39. 2.3.5
      40. 2.3.6
      41. 2.3.7
      42. 2.3.8
      43. 2.3.9
      44. 2.3.10
      45. 2.3.11
      46. 2.3.12
      47. 2.3.13
      48. 2.3.14
      49. 2.3.14.1
      50. 2.3.14.2
      51. 2.3.14.3
      52. 2.3.15
      53. 2.3.15.1
      54. 2.3.15.2
      55. 2.3.15.3
      56. 2.3.16
      57. 2.3.16.1
      58. 2.3.16.2
      59. 2.3.16.3
      60. 2.3.17
      61. 2.3.19
      62. 2.3.20
      63. 2.3.20.1
      64. 2.3.20.2
      65. 2.3.24
      66. 2.3.21
      67. 2.3.22
      68. 2.3.23
      69. 2.3.24.1

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2019-08-23 15:50
2019-08-19 16:44
2017-11-07 19:47
2016-04-12 16:59

New CVE