CVE-2016-3140

The digi_port_init function in drivers/usb/serial/digi_acceleport.c in the Linux kernel before 4.5.1 allows physically proximate attackers to cause a denial of service (NULL pointer dereference and system crash) via a crafted endpoints value in a USB device descriptor.

Published : 2016-05-02 10:59 Updated : 2017-09-08 01:29

4.9
CVSS Score More info
Score 4.9 / 10
4.9
Vendor Product Version URI
Canonical Ubuntu Linux 12.04 cpe:/o:canonical:ubuntu_linux:12.04::~~lts~~~
Novell Suse Linux Enterprise Real Time Extension 11.0 cpe:/o:novell:suse_linux_enterprise_real_time_extension:11.0:sp4
Novell Suse Linux Enterprise Debuginfo 11.0 cpe:/o:novell:suse_linux_enterprise_debuginfo:11.0:sp4
Novell Suse Linux Enterprise Server 12.0 cpe:/o:novell:suse_linux_enterprise_server:12.0
Novell Suse Linux Enterprise Server 12.0 cpe:/o:novell:suse_linux_enterprise_server:12.0:sp1
Novell Suse Linux Enterprise Real Time Extension 12.0 cpe:/o:novell:suse_linux_enterprise_real_time_extension:12.0:sp1
Novell Suse Linux Enterprise Server 11.0 cpe:/o:novell:suse_linux_enterprise_server:11.0:extra
Canonical Ubuntu Linux 14.04 cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~
Novell Suse Linux Enterprise Server 11.0 cpe:/o:novell:suse_linux_enterprise_server:11.0:sp4
Novell Suse Linux Enterprise Live Patching 12.0 cpe:/o:novell:suse_linux_enterprise_live_patching:12.0
Novell Suse Linux Enterprise Workstation Extension 12.0 cpe:/o:novell:suse_linux_enterprise_workstation_extension:12.0
Novell Suse Linux Enterprise Module For Public Cloud 12.0 cpe:/o:novell:suse_linux_enterprise_module_for_public_cloud:12.0
Novell Suse Linux Enterprise Software Development Kit 11.0 cpe:/o:novell:suse_linux_enterprise_software_development_kit:11.0:sp4
Novell Suse Linux Enterprise Workstation Extension 12.0 cpe:/o:novell:suse_linux_enterprise_workstation_extension:12.0:sp1
Novell Suse Linux Enterprise Desktop 12.0 cpe:/o:novell:suse_linux_enterprise_desktop:12.0:sp1
Novell Suse Linux Enterprise Software Development Kit 12.0 cpe:/o:novell:suse_linux_enterprise_software_development_kit:12.0:sp1
Linux Linux Kernel 4.5.0 cpe:/o:linux:linux_kernel:4.5.0
Novell Suse Linux Enterprise Desktop 12.0 cpe:/o:novell:suse_linux_enterprise_desktop:12.0
Novell Suse Linux Enterprise Software Development Kit 12.0 cpe:/o:novell:suse_linux_enterprise_software_development_kit:12.0
  1. Linux (1) Search CVE
    1. Linux Kernel (1) Search CVE
      1. 4.5.0
  2. Canonical (1) Search CVE
    1. Ubuntu Linux (2) Search CVE
      1. 12.04
      2. 14.04
  3. Novell (8) Search CVE
    1. Suse Linux Enterprise Module For Public Cloud (1) Search CVE
      1. 12.0
    2. Suse Linux Enterprise Desktop (1) Search CVE
      1. 12.0
    3. Suse Linux Enterprise Server (2) Search CVE
      1. 12.0
      2. 11.0
    4. Suse Linux Enterprise Real Time Extension (2) Search CVE
      1. 11.0
      2. 12.0
    5. Suse Linux Enterprise Software Development Kit (2) Search CVE
      1. 11.0
      2. 12.0
    6. Suse Linux Enterprise Debuginfo (1) Search CVE
      1. 11.0
    7. Suse Linux Enterprise Workstation Extension (1) Search CVE
      1. 12.0
    8. Suse Linux Enterprise Live Patching (1) Search CVE
      1. 12.0

CWE

There is no CWE for this CVE.

References

Source Link
CONFIRM http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5a07975ad0a36708c6b0a5b9fea1ff811d0b0c1f
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00060.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00056.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00059.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00005.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00038.html
DEBIAN http://www.debian.org/security/2016/dsa-3607
CONFIRM http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.5.1
MLIST http://www.openwall.com/lists/oss-security/2016/03/14/6
BID http://www.securityfocus.com/bid/84304
UBUNTU http://www.ubuntu.com/usn/USN-2968-1
UBUNTU http://www.ubuntu.com/usn/USN-2968-2
UBUNTU http://www.ubuntu.com/usn/USN-2970-1
UBUNTU http://www.ubuntu.com/usn/USN-2971-1
UBUNTU http://www.ubuntu.com/usn/USN-2971-2
UBUNTU http://www.ubuntu.com/usn/USN-2971-3
UBUNTU http://www.ubuntu.com/usn/USN-2996-1
UBUNTU http://www.ubuntu.com/usn/USN-2997-1
UBUNTU http://www.ubuntu.com/usn/USN-3000-1
CONFIRM https://bugzilla.redhat.com/show_bug.cgi?id=1316995
CONFIRM https://github.com/torvalds/linux/commit/5a07975ad0a36708c6b0a5b9fea1ff811d0b0c1f
EXPLOIT-DB https://www.exploit-db.com/exploits/39537/

History of changes

Date Event
2017-09-08 05:34
2016-05-02 10:59

New CVE