CVE-2017-1001000

The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows remote attackers to modify arbitrary pages via a request for wp-json/wp/v2/posts followed by a numeric value and a non-numeric value, as demonstrated by the wp-json/wp/v2/posts/123?id=123helloworld URI.

Published : 2017-04-03 01:59 Updated : 2019-10-03 00:03

5.0
CVSS Score More info
Score 5.0 / 10
5.0
Vendor Product Version URI
Wordpress Wordpress 4.7.1 cpe:/a:wordpress:wordpress:4.7.1
Wordpress Wordpress 4.7.2 cpe:/a:wordpress:wordpress:4.7.2
Wordpress Wordpress 4.7 cpe:/a:wordpress:wordpress:4.7
  1. Wordpress (1) Search CVE
    1. Wordpress (3) Search CVE
      1. 4.7.1
      2. 4.7.2
      3. 4.7

CWE

There is no CWE for this CVE.

History of changes

Date Event
2019-10-03 00:03
2017-07-25 05:31
2017-04-03 01:59

New CVE