CVE-2017-12148

A flaw was found in Ansible Tower's interface before 3.1.5 and 3.2.0 with SCM repositories. If a Tower project (SCM repository) definition does not have the 'delete before update' flag set, an attacker with commit access to the upstream playbook source repository could create a Trojan playbook that, when executed by Tower, modifies the checked out SCM repository to add git hooks. These git hooks could, in turn, cause arbitrary command and code execution as the user Tower runs as.

Published : 2018-07-27 16:29 Updated : 2018-10-01 17:33

9.0
CVSS Score More info
Score 9.0 / 10
9.0
Vendor Product Version URI
Redhat Ansible Tower 1.2.2 cpe:/a:redhat:ansible_tower:1.2.2
Redhat Ansible Tower 1.3.0 cpe:/a:redhat:ansible_tower:1.3.0
Redhat Ansible Tower 1.4.0 cpe:/a:redhat:ansible_tower:1.4.0
Redhat Ansible Tower 1.4.5 cpe:/a:redhat:ansible_tower:1.4.5
Redhat Ansible Tower 1.4.8 cpe:/a:redhat:ansible_tower:1.4.8
Redhat Ansible Tower 1.4.9 cpe:/a:redhat:ansible_tower:1.4.9
Redhat Ansible Tower 1.4.10 cpe:/a:redhat:ansible_tower:1.4.10
Redhat Ansible Tower 1.4.11 cpe:/a:redhat:ansible_tower:1.4.11
Redhat Ansible Tower 1.4.12 cpe:/a:redhat:ansible_tower:1.4.12
Redhat Ansible Tower 2.0.0 cpe:/a:redhat:ansible_tower:2.0.0
Redhat Ansible Tower 2.0.1 cpe:/a:redhat:ansible_tower:2.0.1
Redhat Ansible Tower 2.0.2 cpe:/a:redhat:ansible_tower:2.0.2
Redhat Ansible Tower 2.0.3 cpe:/a:redhat:ansible_tower:2.0.3
Redhat Ansible Tower 2.0.4 cpe:/a:redhat:ansible_tower:2.0.4
Redhat Ansible Tower 2.1 cpe:/a:redhat:ansible_tower:2.1
Redhat Ansible Tower 2.1.1 cpe:/a:redhat:ansible_tower:2.1.1
Redhat Ansible Tower 2.1.2 cpe:/a:redhat:ansible_tower:2.1.2
Redhat Ansible Tower 2.1.3 cpe:/a:redhat:ansible_tower:2.1.3
Redhat Ansible Tower 2.1.4 cpe:/a:redhat:ansible_tower:2.1.4
Redhat Ansible Tower 2.1.5 cpe:/a:redhat:ansible_tower:2.1.5
Redhat Ansible Tower 2.1.6 cpe:/a:redhat:ansible_tower:2.1.6
Redhat Ansible Tower 2.2.0 cpe:/a:redhat:ansible_tower:2.2.0
Redhat Ansible Tower 2.2.1 cpe:/a:redhat:ansible_tower:2.2.1
Redhat Ansible Tower 2.2.2 cpe:/a:redhat:ansible_tower:2.2.2
Redhat Ansible Tower 2.3.0 cpe:/a:redhat:ansible_tower:2.3.0
Redhat Ansible Tower 2.3.1 cpe:/a:redhat:ansible_tower:2.3.1
Redhat Ansible Tower 2.4.0 cpe:/a:redhat:ansible_tower:2.4.0
Redhat Ansible Tower 2.4.3 cpe:/a:redhat:ansible_tower:2.4.3
Redhat Ansible Tower 2.4.4 cpe:/a:redhat:ansible_tower:2.4.4
Redhat Ansible Tower 2.4.5 cpe:/a:redhat:ansible_tower:2.4.5
Redhat Ansible Tower 3.0 cpe:/a:redhat:ansible_tower:3.0
Redhat Ansible Tower 3.0.1 cpe:/a:redhat:ansible_tower:3.0.1
Redhat Ansible Tower 3.0.2 cpe:/a:redhat:ansible_tower:3.0.2
Redhat Ansible Tower 3.0.3 cpe:/a:redhat:ansible_tower:3.0.3
Redhat Ansible Tower 3.0.4 cpe:/a:redhat:ansible_tower:3.0.4
Redhat Ansible Tower 3.1.0 cpe:/a:redhat:ansible_tower:3.1.0
Redhat Ansible Tower 3.1.1 cpe:/a:redhat:ansible_tower:3.1.1
Redhat Ansible Tower 3.1.2 cpe:/a:redhat:ansible_tower:3.1.2
Redhat Ansible Tower 3.1.3 cpe:/a:redhat:ansible_tower:3.1.3
Redhat Ansible Tower 3.1.4 cpe:/a:redhat:ansible_tower:3.1.4
Redhat Cloudforms 4.5 cpe:/a:redhat:cloudforms:4.5
  1. Redhat (2) Search CVE
    1. Cloudforms (1) Search CVE
      1. 4.5
    2. Ansible Tower (40) Search CVE
      1. 1.2.2
      2. 1.3.0
      3. 1.4.0
      4. 1.4.5
      5. 1.4.8
      6. 1.4.9
      7. 1.4.10
      8. 1.4.11
      9. 1.4.12
      10. 2.0.0
      11. 2.0.1
      12. 2.0.2
      13. 2.0.3
      14. 2.0.4
      15. 2.1
      16. 2.1.1
      17. 2.1.2
      18. 2.1.3
      19. 2.1.4
      20. 2.1.5
      21. 2.1.6
      22. 2.2.0
      23. 2.2.1
      24. 2.2.2
      25. 2.3.0
      26. 2.3.1
      27. 2.4.0
      28. 2.4.3
      29. 2.4.4
      30. 2.4.5
      31. 3.0
      32. 3.0.1
      33. 3.0.2
      34. 3.0.3
      35. 3.0.4
      36. 3.1.0
      37. 3.1.1
      38. 3.1.2
      39. 3.1.3
      40. 3.1.4

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2018-10-01 17:33
2018-07-29 01:29
2018-07-27 16:29

New CVE