CVE-2017-4970

An issue was discovered in Cloud Foundry Foundation cf-release v255 and Staticfile buildpack versions v1.4.0 - v1.4.3. A regression introduced in the Static file build pack causes the Staticfile.auth configuration to be ignored when the Static file file is not present in the application root. Applications containing a Staticfile.auth file but not a Static file had their basic auth turned off when an operator upgraded the Static file build pack in the foundation to one of the vulnerable versions. Note that Static file applications without a Static file are technically misconfigured, and will not successfully detect unless the Static file build pack is explicitly specified.

Published : 2017-06-13 06:29 Updated : 2019-10-03 00:03

4.3
CVSS Score More info
Score 4.3 / 10
4.3
Vendor Product Version URI
Cloudfoundry Cf-release 255 cpe:/a:cloudfoundry:cf-release:255
Cloudfoundry Staticfile Buildpack 1.4.0 cpe:/a:cloudfoundry:staticfile_buildpack:1.4.0
Cloudfoundry Staticfile Buildpack 1.4.1 cpe:/a:cloudfoundry:staticfile_buildpack:1.4.1
Cloudfoundry Staticfile Buildpack 1.4.2 cpe:/a:cloudfoundry:staticfile_buildpack:1.4.2
Cloudfoundry Staticfile Buildpack 1.4.3 cpe:/a:cloudfoundry:staticfile_buildpack:1.4.3
  1. Cloudfoundry (2) Search CVE
    1. Cf-release (1) Search CVE
      1. 255
    2. Staticfile Buildpack (4) Search CVE
      1. 1.4.0
      2. 1.4.1
      3. 1.4.2
      4. 1.4.3

CWE

There is no CWE for this CVE.

Reference

History of changes

Date Event
2019-10-03 00:03
2017-11-08 12:58
2017-06-26 18:29
2017-06-13 06:29

New CVE