CVE-2017-7506

spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into crash and/or server memory leak.

Published : 2017-07-18 15:29 Updated : 2018-11-08 11:29

6.5
CVSS Score More info
Score 6.5 / 10
6.5
Vendor Product Version URI
Spice Project Spice 0.12.4 cpe:/a:spice_project:spice:0.12.4
Spice Project Spice 0.12.3 cpe:/a:spice_project:spice:0.12.3
Spice Project Spice 0.12.6 cpe:/a:spice_project:spice:0.12.6
Spice Project Spice 0.6.0 cpe:/a:spice_project:spice:0.6.0
Spice Project Spice 0.12.5 cpe:/a:spice_project:spice:0.12.5
Spice Project Spice 0.5.2 cpe:/a:spice_project:spice:0.5.2
Spice Project Spice 0.6.1 cpe:/a:spice_project:spice:0.6.1
Spice Project Spice 0.7.0 cpe:/a:spice_project:spice:0.7.0
Spice Project Spice 0.5.3 cpe:/a:spice_project:spice:0.5.3
Spice Project Spice 0.6.2 cpe:/a:spice_project:spice:0.6.2
Spice Project Spice 0.7.1 cpe:/a:spice_project:spice:0.7.1
Spice Project Spice 0.8.0 cpe:/a:spice_project:spice:0.8.0
Spice Project Spice 0.12.0 cpe:/a:spice_project:spice:0.12.0
Spice Project Spice 0.6.3 cpe:/a:spice_project:spice:0.6.3
Spice Project Spice 0.7.2 cpe:/a:spice_project:spice:0.7.2
Spice Project Spice 0.8.1 cpe:/a:spice_project:spice:0.8.1
Spice Project Spice 0.9.0 cpe:/a:spice_project:spice:0.9.0
Spice Project Spice 0.10.1 cpe:/a:spice_project:spice:0.10.1
Spice Project Spice 0.11.0 cpe:/a:spice_project:spice:0.11.0
Spice Project Spice 0.6.4 cpe:/a:spice_project:spice:0.6.4
Spice Project Spice 0.7.3 cpe:/a:spice_project:spice:0.7.3
Spice Project Spice 0.8.2 cpe:/a:spice_project:spice:0.8.2
Spice Project Spice 0.9.1 cpe:/a:spice_project:spice:0.9.1
Spice Project Spice 0.11.3 cpe:/a:spice_project:spice:0.11.3
Spice Project Spice 0.12.2 cpe:/a:spice_project:spice:0.12.2
Spice Project Spice 0.13.0 cpe:/a:spice_project:spice:0.13.0
Spice Project Spice 0.8.3 cpe:/a:spice_project:spice:0.8.3
Spice Project Spice 0.10.0 cpe:/a:spice_project:spice:0.10.0
Spice Project Spice 0.12.8 cpe:/a:spice_project:spice:0.12.8
Spice Project Spice 0.12.7 cpe:/a:spice_project:spice:0.12.7
  1. Spice Project (1) Search CVE
    1. Spice (30) Search CVE
      1. 0.12.4
      2. 0.12.3
      3. 0.12.6
      4. 0.6.0
      5. 0.12.5
      6. 0.5.2
      7. 0.6.1
      8. 0.7.0
      9. 0.5.3
      10. 0.6.2
      11. 0.7.1
      12. 0.8.0
      13. 0.12.0
      14. 0.6.3
      15. 0.7.2
      16. 0.8.1
      17. 0.9.0
      18. 0.10.1
      19. 0.11.0
      20. 0.6.4
      21. 0.7.3
      22. 0.8.2
      23. 0.9.1
      24. 0.11.3
      25. 0.12.2
      26. 0.13.0
      27. 0.8.3
      28. 0.10.0
      29. 0.12.8
      30. 0.12.7

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

History of changes

Date Event
2018-11-08 11:29
2018-01-05 02:31
2017-11-04 01:29
2017-08-08 16:27
2017-07-20 06:04
2017-07-18 15:29

New CVE