CVE-2018-0337

A vulnerability in the role-based access-checking mechanisms of Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary commands on an affected device. The vulnerability exists because the affected software lacks proper input and validation checks for certain file systems. An attacker could exploit this vulnerability by issuing crafted commands in the CLI of an affected device. A successful exploit could allow the attacker to cause other users to execute unwanted, arbitrary commands on the affected device. Cisco Bug IDs: CSCvd06339, CSCvd15698, CSCvd36108, CSCvf52921, CSCvf52930, CSCvf52953, CSCvf52976.

Published : 2018-06-21 11:29 Updated : 2019-10-09 23:31

7.2
CVSS Score More info
Score 7.2 / 10
7.2
Vendor Product Version URI
Cisco Nx-os 7.0%288%29n1%281%29 cpe:/o:cisco:nx-os:7.0%288%29n1%281%29
Cisco Nx-os 7.1%284%29n1%281%29 cpe:/o:cisco:nx-os:7.1%284%29n1%281%29
Cisco Nx-os 7.3%281%29dx%280.119%29 cpe:/o:cisco:nx-os:7.3%281%29dx%280.119%29
Cisco Nx-os 7.3%281%29n1%280.6%29 cpe:/o:cisco:nx-os:7.3%281%29n1%280.6%29
Cisco Nx-os 7.3%282%29n1%280.350%29 cpe:/o:cisco:nx-os:7.3%282%29n1%280.350%29
Cisco Nx-os 7.3%283%29d1%280.2%29 cpe:/o:cisco:nx-os:7.3%283%29d1%280.2%29
Cisco Nx-os 8.0%280.54%29s0 cpe:/o:cisco:nx-os:8.0%280.54%29s0
Cisco Nx-os 8.1%280%29bd%280.20%29 cpe:/o:cisco:nx-os:8.1%280%29bd%280.20%29
Cisco Nx-os 8.1%280.9%29 cpe:/o:cisco:nx-os:8.1%280.9%29
Cisco Nx-os 8.2%280.4%29s0 cpe:/o:cisco:nx-os:8.2%280.4%29s0
Cisco Nx-os 8.3%280%29spg%280.30%29 cpe:/o:cisco:nx-os:8.3%280%29spg%280.30%29
Cisco Nx-os 8.8%283.5%29s0 cpe:/o:cisco:nx-os:8.8%283.5%29s0
  1. Cisco (1) Search CVE
    1. Nx-os (12) Search CVE
      1. 7.0%288%29n1%281%29
      2. 7.1%284%29n1%281%29
      3. 7.3%281%29dx%280.119%29
      4. 7.3%281%29n1%280.6%29
      5. 7.3%282%29n1%280.350%29
      6. 7.3%283%29d1%280.2%29
      7. 8.0%280.54%29s0
      8. 8.1%280%29bd%280.20%29
      9. 8.1%280.9%29
      10. 8.2%280.4%29s0
      11. 8.3%280%29spg%280.30%29
      12. 8.8%283.5%29s0

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2018-08-20 22:54
2018-06-21 11:29

New CVE