CVE-2018-1071

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the exec.c:hashcmd() function. A local attacker could exploit this to cause a denial of service.

Published : 2018-03-09 15:29 Updated : 2019-10-09 23:38

2.1
CVSS Score More info
Score 2.1 / 10
2.1
Vendor Product Version URI
Zsh Zsh 5.4.2 cpe:/a:zsh:zsh:5.4.2
Canonical Ubuntu Linux 14.04 cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~
Canonical Ubuntu Linux 16.04 cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~
Canonical Ubuntu Linux 17.10 cpe:/o:canonical:ubuntu_linux:17.10
Debian Debian Linux 7.0 cpe:/o:debian:debian_linux:7.0
Redhat Enterprise Linux Desktop 7.0 cpe:/o:redhat:enterprise_linux_desktop:7.0
Redhat Enterprise Linux Server 7.0 cpe:/o:redhat:enterprise_linux_server:7.0
Redhat Enterprise Linux Workstation 7.0 cpe:/o:redhat:enterprise_linux_workstation:7.0
  1. Canonical (1) Search CVE
    1. Ubuntu Linux (3) Search CVE
      1. 14.04
      2. 16.04
      3. 17.10
  2. Redhat (3) Search CVE
    1. Enterprise Linux Desktop (1) Search CVE
      1. 7.0
    2. Enterprise Linux Workstation (1) Search CVE
      1. 7.0
    3. Enterprise Linux Server (1) Search CVE
      1. 7.0
  3. Zsh (1) Search CVE
    1. Zsh (1) Search CVE
      1. 5.4.2
  4. Debian (1) Search CVE
    1. Debian Linux (1) Search CVE
      1. 7.0

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

History of changes

Date Event
2019-03-20 13:54
2018-10-31 10:30
2018-10-21 10:29
2018-04-02 01:29
2018-03-30 01:29
2018-03-27 16:43
2018-03-14 01:29
2018-03-09 15:29

New CVE