CVE-2018-10874

In ansible it was found that inventory variables are loaded from current working directory when running ad-hoc command which are under attacker's control, allowing to run arbitrary code as a result.

Published : 2018-07-02 13:29 Updated : 2019-07-25 02:15

4.6
CVSS Score More info
Score 4.6 / 10
4.6
Vendor Product Version URI
Redhat Openstack 10 cpe:/a:redhat:openstack:10
Redhat Openstack 12 cpe:/a:redhat:openstack:12
Redhat Virtualization Host 4.0 cpe:/a:redhat:virtualization_host:4.0
Redhat Ansible Engine 2.0 cpe:/a:redhat:ansible_engine:2.0
Redhat Ansible Engine 2.4 cpe:/a:redhat:ansible_engine:2.4
Redhat Ansible Engine 2.5 cpe:/a:redhat:ansible_engine:2.5
Redhat Ansible Engine 2.6 cpe:/a:redhat:ansible_engine:2.6
Redhat Openstack 13.0 cpe:/a:redhat:openstack:13.0
Redhat Virtualization 4.0 cpe:/a:redhat:virtualization:4.0
  1. Redhat (4) Search CVE
    1. Ansible Engine (4) Search CVE
      1. 2.0
      2. 2.4
      3. 2.5
      4. 2.6
    2. Openstack (3) Search CVE
      1. 10
      2. 12
      3. 13.0
    3. Virtualization (1) Search CVE
      1. 4.0
    4. Virtualization Host (1) Search CVE
      1. 4.0

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2019-07-25 02:15
2019-04-23 12:52
2019-01-17 11:29
2018-12-06 11:29
2018-09-04 16:32
2018-08-30 10:29
2018-08-02 01:29
2018-07-12 01:29
2018-07-02 13:29

New CVE