CVE-2018-14042

In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip.

Published : 2018-07-13 14:29 Updated : 2019-05-10 19:29

4.3
CVSS Score More info
Score 4.3 / 10
4.3
Vendor Product Version URI
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:alpha
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:alpha2
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:alpha3
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:alpha4
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:alpha5
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:alpha6
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:beta
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:beta2
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:beta3
Getbootstrap Bootstrap 1.0.0 cpe:/a:getbootstrap:bootstrap:1.0.0
Getbootstrap Bootstrap 1.1.0 cpe:/a:getbootstrap:bootstrap:1.1.0
Getbootstrap Bootstrap 1.1.1 cpe:/a:getbootstrap:bootstrap:1.1.1
Getbootstrap Bootstrap 1.2.0 cpe:/a:getbootstrap:bootstrap:1.2.0
Getbootstrap Bootstrap 1.3.0 cpe:/a:getbootstrap:bootstrap:1.3.0
Getbootstrap Bootstrap 1.4.0 cpe:/a:getbootstrap:bootstrap:1.4.0
Getbootstrap Bootstrap 2.0.0 cpe:/a:getbootstrap:bootstrap:2.0.0
Getbootstrap Bootstrap 2.0.1 cpe:/a:getbootstrap:bootstrap:2.0.1
Getbootstrap Bootstrap 2.0.2 cpe:/a:getbootstrap:bootstrap:2.0.2
Getbootstrap Bootstrap 2.0.3 cpe:/a:getbootstrap:bootstrap:2.0.3
Getbootstrap Bootstrap 2.0.4 cpe:/a:getbootstrap:bootstrap:2.0.4
Getbootstrap Bootstrap 2.1.0 cpe:/a:getbootstrap:bootstrap:2.1.0
Getbootstrap Bootstrap 2.1.1 cpe:/a:getbootstrap:bootstrap:2.1.1
Getbootstrap Bootstrap 2.2.0 cpe:/a:getbootstrap:bootstrap:2.2.0
Getbootstrap Bootstrap 2.2.1 cpe:/a:getbootstrap:bootstrap:2.2.1
Getbootstrap Bootstrap 2.2.2 cpe:/a:getbootstrap:bootstrap:2.2.2
Getbootstrap Bootstrap 2.3.0 cpe:/a:getbootstrap:bootstrap:2.3.0
Getbootstrap Bootstrap 2.3.1 cpe:/a:getbootstrap:bootstrap:2.3.1
Getbootstrap Bootstrap 2.3.2 cpe:/a:getbootstrap:bootstrap:2.3.2
Getbootstrap Bootstrap 3.0.0 cpe:/a:getbootstrap:bootstrap:3.0.0:-
Getbootstrap Bootstrap 3.0.0 cpe:/a:getbootstrap:bootstrap:3.0.0:rc1
Getbootstrap Bootstrap 3.0.0 cpe:/a:getbootstrap:bootstrap:3.0.0:rc2
Getbootstrap Bootstrap 3.0.1 cpe:/a:getbootstrap:bootstrap:3.0.1
Getbootstrap Bootstrap 3.0.2 cpe:/a:getbootstrap:bootstrap:3.0.2
Getbootstrap Bootstrap 3.0.3 cpe:/a:getbootstrap:bootstrap:3.0.3
Getbootstrap Bootstrap 3.1.0 cpe:/a:getbootstrap:bootstrap:3.1.0
Getbootstrap Bootstrap 3.1.1 cpe:/a:getbootstrap:bootstrap:3.1.1
Getbootstrap Bootstrap 3.2.0 cpe:/a:getbootstrap:bootstrap:3.2.0
Getbootstrap Bootstrap 3.3.0 cpe:/a:getbootstrap:bootstrap:3.3.0
Getbootstrap Bootstrap 3.3.1 cpe:/a:getbootstrap:bootstrap:3.3.1
Getbootstrap Bootstrap 3.3.2 cpe:/a:getbootstrap:bootstrap:3.3.2
Getbootstrap Bootstrap 3.3.4 cpe:/a:getbootstrap:bootstrap:3.3.4
Getbootstrap Bootstrap 3.3.5 cpe:/a:getbootstrap:bootstrap:3.3.5
Getbootstrap Bootstrap 3.3.6 cpe:/a:getbootstrap:bootstrap:3.3.6
Getbootstrap Bootstrap 3.3.7 cpe:/a:getbootstrap:bootstrap:3.3.7
Getbootstrap Bootstrap 4.0.0 cpe:/a:getbootstrap:bootstrap:4.0.0:-
Getbootstrap Bootstrap 4.1.0 cpe:/a:getbootstrap:bootstrap:4.1.0
Getbootstrap Bootstrap 4.1.1 cpe:/a:getbootstrap:bootstrap:4.1.1
  1. Getbootstrap (1) Search CVE
    1. Bootstrap (36) Search CVE
      1. 4.0.0
      2. 1.0.0
      3. 1.1.0
      4. 1.1.1
      5. 1.2.0
      6. 1.3.0
      7. 1.4.0
      8. 2.0.0
      9. 2.0.1
      10. 2.0.2
      11. 2.0.3
      12. 2.0.4
      13. 2.1.0
      14. 2.1.1
      15. 2.2.0
      16. 2.2.1
      17. 2.2.2
      18. 2.3.0
      19. 2.3.1
      20. 2.3.2
      21. 3.0.0
      22. 3.0.1
      23. 3.0.2
      24. 3.0.3
      25. 3.1.0
      26. 3.1.1
      27. 3.2.0
      28. 3.3.0
      29. 3.3.1
      30. 3.3.2
      31. 3.3.4
      32. 3.3.5
      33. 3.3.6
      34. 3.3.7
      35. 4.1.0
      36. 4.1.1

CWE

ID Name Description Links
CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. CVE

History of changes

Date Event
2019-05-10 19:29
2019-05-09 18:29
2019-01-09 17:33
2018-09-05 18:58
2018-07-13 14:29

New CVE