CVE-2018-16514

A cross-site scripting (XSS) vulnerability in the View Filters page (view_filters_page.php) and Edit Filter page (manage_filter_edit_page.php) in MantisBT 2.1.0 through 2.17.0 allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted PATH_INFO. NOTE: this vulnerability exists because of an incomplete fix for CVE-2018-13055.

Published : 2019-06-20 14:15 Updated : 2019-06-21 16:12

2.6
CVSS Score More info
Score 2.6 / 10
2.6
Vendor Product Version URI
Mantisbt Mantisbt 2.1.0 cpe:/a:mantisbt:mantisbt:2.1.0
Mantisbt Mantisbt 2.1.1 cpe:/a:mantisbt:mantisbt:2.1.1
Mantisbt Mantisbt 2.1.2 cpe:/a:mantisbt:mantisbt:2.1.2
Mantisbt Mantisbt 2.1.3 cpe:/a:mantisbt:mantisbt:2.1.3
Mantisbt Mantisbt 2.2.0 cpe:/a:mantisbt:mantisbt:2.2.0
Mantisbt Mantisbt 2.2.1 cpe:/a:mantisbt:mantisbt:2.2.1
Mantisbt Mantisbt 2.2.2 cpe:/a:mantisbt:mantisbt:2.2.2
Mantisbt Mantisbt 2.2.3 cpe:/a:mantisbt:mantisbt:2.2.3
Mantisbt Mantisbt 2.2.4 cpe:/a:mantisbt:mantisbt:2.2.4
Mantisbt Mantisbt 2.3.0 cpe:/a:mantisbt:mantisbt:2.3.0
Mantisbt Mantisbt 2.3.1 cpe:/a:mantisbt:mantisbt:2.3.1
Mantisbt Mantisbt 2.3.2 cpe:/a:mantisbt:mantisbt:2.3.2
Mantisbt Mantisbt 2.3.3 cpe:/a:mantisbt:mantisbt:2.3.3
Mantisbt Mantisbt 2.4.0 cpe:/a:mantisbt:mantisbt:2.4.0
Mantisbt Mantisbt 2.4.1 cpe:/a:mantisbt:mantisbt:2.4.1
Mantisbt Mantisbt 2.4.2 cpe:/a:mantisbt:mantisbt:2.4.2
Mantisbt Mantisbt 2.5.0 cpe:/a:mantisbt:mantisbt:2.5.0
Mantisbt Mantisbt 2.5.1 cpe:/a:mantisbt:mantisbt:2.5.1
Mantisbt Mantisbt 2.5.2 cpe:/a:mantisbt:mantisbt:2.5.2
Mantisbt Mantisbt 2.6.0 cpe:/a:mantisbt:mantisbt:2.6.0
Mantisbt Mantisbt 2.7.0 cpe:/a:mantisbt:mantisbt:2.7.0
Mantisbt Mantisbt 2.7.1 cpe:/a:mantisbt:mantisbt:2.7.1
Mantisbt Mantisbt 2.8.0 cpe:/a:mantisbt:mantisbt:2.8.0
Mantisbt Mantisbt 2.8.1 cpe:/a:mantisbt:mantisbt:2.8.1
Mantisbt Mantisbt 2.9.0 cpe:/a:mantisbt:mantisbt:2.9.0
Mantisbt Mantisbt 2.9.1 cpe:/a:mantisbt:mantisbt:2.9.1
Mantisbt Mantisbt 2.10.0 cpe:/a:mantisbt:mantisbt:2.10.0
Mantisbt Mantisbt 2.10.1 cpe:/a:mantisbt:mantisbt:2.10.1
Mantisbt Mantisbt 2.11.0 cpe:/a:mantisbt:mantisbt:2.11.0
Mantisbt Mantisbt 2.11.1 cpe:/a:mantisbt:mantisbt:2.11.1
Mantisbt Mantisbt 2.12.0 cpe:/a:mantisbt:mantisbt:2.12.0
Mantisbt Mantisbt 2.12.1 cpe:/a:mantisbt:mantisbt:2.12.1
Mantisbt Mantisbt 2.12.2 cpe:/a:mantisbt:mantisbt:2.12.2
Mantisbt Mantisbt 2.13.0 cpe:/a:mantisbt:mantisbt:2.13.0
Mantisbt Mantisbt 2.13.1 cpe:/a:mantisbt:mantisbt:2.13.1
Mantisbt Mantisbt 2.13.2 cpe:/a:mantisbt:mantisbt:2.13.2
Mantisbt Mantisbt 2.14.0 cpe:/a:mantisbt:mantisbt:2.14.0
Mantisbt Mantisbt 2.15.0 cpe:/a:mantisbt:mantisbt:2.15.0
Mantisbt Mantisbt 2.15.1 cpe:/a:mantisbt:mantisbt:2.15.1
Mantisbt Mantisbt 2.16.0 cpe:/a:mantisbt:mantisbt:2.16.0
Mantisbt Mantisbt 2.16.1 cpe:/a:mantisbt:mantisbt:2.16.1
Mantisbt Mantisbt 2.17.0 cpe:/a:mantisbt:mantisbt:2.17.0
  1. Mantisbt (1) Search CVE
    1. Mantisbt (42) Search CVE
      1. 2.1.0
      2. 2.1.1
      3. 2.1.2
      4. 2.1.3
      5. 2.2.0
      6. 2.2.1
      7. 2.2.2
      8. 2.2.3
      9. 2.2.4
      10. 2.3.0
      11. 2.3.1
      12. 2.3.2
      13. 2.3.3
      14. 2.4.0
      15. 2.4.1
      16. 2.4.2
      17. 2.5.0
      18. 2.5.1
      19. 2.5.2
      20. 2.6.0
      21. 2.7.0
      22. 2.7.1
      23. 2.8.0
      24. 2.8.1
      25. 2.9.0
      26. 2.9.1
      27. 2.10.0
      28. 2.10.1
      29. 2.11.0
      30. 2.11.1
      31. 2.12.0
      32. 2.12.1
      33. 2.12.2
      34. 2.13.0
      35. 2.13.1
      36. 2.13.2
      37. 2.14.0
      38. 2.15.0
      39. 2.15.1
      40. 2.16.0
      41. 2.16.1
      42. 2.17.0

CWE

ID Name Description Links
CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users. CVE

Reference

History of changes

Date Event
2019-06-21 16:12
2019-06-20 14:24

New CVE