CVE-2018-17196

In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

Published : 2019-07-11 21:15 Updated : 2019-08-02 20:15

6.5
CVSS Score More info
Score 6.5 / 10
6.5
Vendor Product Version URI
Apache Kafka 0.11.0.0 cpe:/a:apache:kafka:0.11.0.0
Apache Kafka 0.11.0.1 cpe:/a:apache:kafka:0.11.0.1
Apache Kafka 0.11.0.2 cpe:/a:apache:kafka:0.11.0.2
Apache Kafka 0.11.0.3 cpe:/a:apache:kafka:0.11.0.3
Apache Kafka 1.0.0 cpe:/a:apache:kafka:1.0.0
Apache Kafka 1.0.1 cpe:/a:apache:kafka:1.0.1
Apache Kafka 1.0.2 cpe:/a:apache:kafka:1.0.2
Apache Kafka 1.1.0 cpe:/a:apache:kafka:1.1.0
Apache Kafka 1.1.1 cpe:/a:apache:kafka:1.1.1
Apache Kafka 2.0.0 cpe:/a:apache:kafka:2.0.0
Apache Kafka 2.1.0 cpe:/a:apache:kafka:2.1.0
  1. Apache (1) Search CVE
    1. Kafka (11) Search CVE
      1. 0.11.0.0
      2. 0.11.0.1
      3. 0.11.0.2
      4. 0.11.0.3
      5. 1.0.0
      6. 1.0.1
      7. 1.0.2
      8. 1.1.0
      9. 1.1.1
      10. 2.0.0
      11. 2.1.0

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2019-08-02 20:15
2019-07-18 14:21
2019-07-11 21:17

New CVE