CVE-2018-1999038

A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin 0.10 and earlier in CifsPublisherPluginDescriptor.java that allows attackers to have Jenkins connect to an attacker specified CIFS server with attacker specified credentials.

Published : 2018-08-01 13:29 Updated : 2018-10-15 15:32

4.9
CVSS Score More info
Score 4.9 / 10
4.9
Vendor Product Version URI
Jenkins Publish Over Cifs 0.10 cpe:/a:jenkins:publish_over_cifs:0.10::~~~jenkins~~
  1. Jenkins (1) Search CVE
    1. Publish Over Cifs (1) Search CVE
      1. 0.10

CWE

ID Name Description Links
CWE-441 Unintended Proxy or Intermediary ('Confused Deputy') The software receives a request, message, or directive from an upstream component, but the software does not sufficiently preserve the original source of the request before forwarding the request to an external actor that is outside of the software's control sphere. This causes the software to appear to be the source of the request, leading it to act as a proxy or other intermediary between the upstream component and the external actor. CVE

History of changes

Date Event
2018-10-15 15:32
2018-08-01 13:29

New CVE