CVE-2018-7750

transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before 1.18.5, 2.0.x before 2.0.8, 2.1.x before 2.1.5, 2.2.x before 2.2.3, 2.3.x before 2.3.2, and 2.4.x before 2.4.1 does not properly check whether authentication is completed before processing other requests, as demonstrated by channel-open. A customized SSH client can simply skip the authentication step.

Published : 2018-03-13 18:29 Updated : 2019-02-28 19:20

7.5
CVSS Score More info
Score 7.5 / 10
7.5
Vendor Product Version URI
Paramiko Paramiko 2.4.0 cpe:/a:paramiko:paramiko:2.4.0
Redhat Ansible Engine 2.0 cpe:/a:redhat:ansible_engine:2.0
Redhat Ansible Engine 2.4 cpe:/a:redhat:ansible_engine:2.4
Redhat Cloudforms 4.5 cpe:/a:redhat:cloudforms:4.5
Redhat Cloudforms 4.6 cpe:/a:redhat:cloudforms:4.6
Debian Debian Linux 8.0 cpe:/o:debian:debian_linux:8.0
Redhat Enterprise Linux Desktop 6.0 cpe:/o:redhat:enterprise_linux_desktop:6.0
Redhat Enterprise Linux Server 6.0 cpe:/o:redhat:enterprise_linux_server:6.0
Redhat Enterprise Linux Server 7.0 cpe:/o:redhat:enterprise_linux_server:7.0
Redhat Enterprise Linux Server Aus 6.4 cpe:/o:redhat:enterprise_linux_server_aus:6.4
Redhat Enterprise Linux Server Aus 6.5 cpe:/o:redhat:enterprise_linux_server_aus:6.5
Redhat Enterprise Linux Server Aus 6.6 cpe:/o:redhat:enterprise_linux_server_aus:6.6
Redhat Enterprise Linux Server Eus 6.7 cpe:/o:redhat:enterprise_linux_server_eus:6.7
Redhat Enterprise Linux Server Tus 6.6 cpe:/o:redhat:enterprise_linux_server_tus:6.6
Redhat Enterprise Linux Workstation 6.0 cpe:/o:redhat:enterprise_linux_workstation:6.0
Redhat Virtualization 4.0 cpe:/o:redhat:virtualization:4.0
Redhat Virtualization 4.1 cpe:/o:redhat:virtualization:4.1
  1. Redhat (9) Search CVE
    1. Enterprise Linux Server Aus (3) Search CVE
      1. 6.4
      2. 6.5
      3. 6.6
    2. Virtualization (2) Search CVE
      1. 4.0
      2. 4.1
    3. Enterprise Linux Server Tus (1) Search CVE
      1. 6.6
    4. Enterprise Linux Desktop (1) Search CVE
      1. 6.0
    5. Enterprise Linux Server (2) Search CVE
      1. 6.0
      2. 7.0
    6. Ansible Engine (2) Search CVE
      1. 2.0
      2. 2.4
    7. Enterprise Linux Server Eus (1) Search CVE
      1. 6.7
    8. Enterprise Linux Workstation (1) Search CVE
      1. 6.0
    9. Cloudforms (2) Search CVE
      1. 4.5
      2. 4.6
  2. Debian (1) Search CVE
    1. Debian Linux (1) Search CVE
      1. 8.0
  3. Paramiko (1) Search CVE
    1. Paramiko (1) Search CVE
      1. 2.4.0

CWE

ID Name Description Links
CWE-287 Improper Authentication When an actor claims to have a given identity, the software does not prove or insufficiently proves that the claim is correct. CVE

History of changes

Date Event
2019-02-28 19:20
2018-10-31 10:32
2018-10-29 12:29
2018-06-27 01:29
2018-05-17 01:29
2018-05-08 13:29
2018-05-04 01:29
2018-04-26 01:29
2018-04-16 09:58
2018-04-11 17:37
2018-04-07 01:29
2018-04-05 01:29
2018-03-28 01:29
2018-03-22 01:29
2018-03-16 01:29
2018-03-13 18:29

New CVE