CVE-2019-11042

When PHP EXIF extension is parsing EXIF information from an image, e.g. via exif_read_data() function, in PHP versions 7.1.x below 7.1.31, 7.2.x below 7.2.21 and 7.3.x below 7.3.8 it is possible to supply it with data what will cause it to read past the allocated buffer. This may lead to information disclosure or crash.

Published : 2019-08-09 20:15 Updated : 2019-08-22 07:15

6.8
CVSS Score More info
Score 6.8 / 10
6.8
Vendor Product Version URI
Php Php 7.1.0 cpe:/a:php:php:7.1.0
Php Php 7.1.0 cpe:/a:php:php:7.1.0:-
Php Php 7.1.0 cpe:/a:php:php:7.1.0:alpha1
Php Php 7.1.0 cpe:/a:php:php:7.1.0:alpha2
Php Php 7.1.0 cpe:/a:php:php:7.1.0:alpha3
Php Php 7.1.0 cpe:/a:php:php:7.1.0:beta1
Php Php 7.1.0 cpe:/a:php:php:7.1.0:beta2
Php Php 7.1.0 cpe:/a:php:php:7.1.0:beta3
Php Php 7.1.0 cpe:/a:php:php:7.1.0:rc1
Php Php 7.1.0 cpe:/a:php:php:7.1.0:rc2
Php Php 7.1.0 cpe:/a:php:php:7.1.0:rc3
Php Php 7.1.0 cpe:/a:php:php:7.1.0:rc4
Php Php 7.1.0 cpe:/a:php:php:7.1.0:rc5
Php Php 7.1.0 cpe:/a:php:php:7.1.0:rc6
Php Php 7.1.1 cpe:/a:php:php:7.1.1
Php Php 7.1.1 cpe:/a:php:php:7.1.1:-
Php Php 7.1.1 cpe:/a:php:php:7.1.1:rc1
Php Php 7.1.2 cpe:/a:php:php:7.1.2
Php Php 7.1.2 cpe:/a:php:php:7.1.2:-
Php Php 7.1.2 cpe:/a:php:php:7.1.2:rc1
Php Php 7.1.3 cpe:/a:php:php:7.1.3
Php Php 7.1.3 cpe:/a:php:php:7.1.3:-
Php Php 7.1.3 cpe:/a:php:php:7.1.3:rc1
Php Php 7.1.4 cpe:/a:php:php:7.1.4
Php Php 7.1.4 cpe:/a:php:php:7.1.4:-
Php Php 7.1.4 cpe:/a:php:php:7.1.4:rc1
Php Php 7.1.5 cpe:/a:php:php:7.1.5
Php Php 7.1.5 cpe:/a:php:php:7.1.5:-
Php Php 7.1.5 cpe:/a:php:php:7.1.5:rc1
Php Php 7.1.6 cpe:/a:php:php:7.1.6
Php Php 7.1.6 cpe:/a:php:php:7.1.6:-
Php Php 7.1.6 cpe:/a:php:php:7.1.6:rc1
Php Php 7.1.7 cpe:/a:php:php:7.1.7
Php Php 7.1.7 cpe:/a:php:php:7.1.7:-
Php Php 7.1.7 cpe:/a:php:php:7.1.7:rc1
Php Php 7.1.8 cpe:/a:php:php:7.1.8
Php Php 7.1.8 cpe:/a:php:php:7.1.8:-
Php Php 7.1.8 cpe:/a:php:php:7.1.8:rc1
Php Php 7.1.9 cpe:/a:php:php:7.1.9
Php Php 7.1.9 cpe:/a:php:php:7.1.9:-
Php Php 7.1.9 cpe:/a:php:php:7.1.9:rc1
Php Php 7.1.10 cpe:/a:php:php:7.1.10
Php Php 7.1.10 cpe:/a:php:php:7.1.10:-
Php Php 7.1.10 cpe:/a:php:php:7.1.10:rc1
Php Php 7.1.11 cpe:/a:php:php:7.1.11
Php Php 7.1.11 cpe:/a:php:php:7.1.11:-
Php Php 7.1.11 cpe:/a:php:php:7.1.11:rc1
Php Php 7.1.12 cpe:/a:php:php:7.1.12
Php Php 7.1.12 cpe:/a:php:php:7.1.12:-
Php Php 7.1.12 cpe:/a:php:php:7.1.12:rc1
Php Php 7.1.13 cpe:/a:php:php:7.1.13
Php Php 7.1.13 cpe:/a:php:php:7.1.13:-
Php Php 7.1.13 cpe:/a:php:php:7.1.13:rc1
Php Php 7.1.14 cpe:/a:php:php:7.1.14
Php Php 7.1.14 cpe:/a:php:php:7.1.14:-
Php Php 7.1.14 cpe:/a:php:php:7.1.14:rc1
Php Php 7.1.15 cpe:/a:php:php:7.1.15
Php Php 7.1.15 cpe:/a:php:php:7.1.15:-
Php Php 7.1.15 cpe:/a:php:php:7.1.15:rc1
Php Php 7.1.16 cpe:/a:php:php:7.1.16
Php Php 7.1.16 cpe:/a:php:php:7.1.16:-
Php Php 7.1.16 cpe:/a:php:php:7.1.16:rc1
Php Php 7.1.17 cpe:/a:php:php:7.1.17
Php Php 7.1.17 cpe:/a:php:php:7.1.17:-
Php Php 7.1.17 cpe:/a:php:php:7.1.17:rc1
Php Php 7.1.18 cpe:/a:php:php:7.1.18
Php Php 7.1.18 cpe:/a:php:php:7.1.18:-
Php Php 7.1.18 cpe:/a:php:php:7.1.18:rc1
Php Php 7.1.19 cpe:/a:php:php:7.1.19
Php Php 7.1.19 cpe:/a:php:php:7.1.19:-
Php Php 7.1.19 cpe:/a:php:php:7.1.19:rc1
Php Php 7.1.20 cpe:/a:php:php:7.1.20
Php Php 7.1.20 cpe:/a:php:php:7.1.20:-
Php Php 7.1.20 cpe:/a:php:php:7.1.20:rc1
Php Php 7.1.21 cpe:/a:php:php:7.1.21
Php Php 7.1.21 cpe:/a:php:php:7.1.21:-
Php Php 7.1.21 cpe:/a:php:php:7.1.21:rc1
Php Php 7.1.22 cpe:/a:php:php:7.1.22
Php Php 7.1.22 cpe:/a:php:php:7.1.22:-
Php Php 7.1.23 cpe:/a:php:php:7.1.23
Php Php 7.1.23 cpe:/a:php:php:7.1.23:-
Php Php 7.1.23 cpe:/a:php:php:7.1.23:rc1
Php Php 7.1.24 cpe:/a:php:php:7.1.24
Php Php 7.1.24 cpe:/a:php:php:7.1.24:-
Php Php 7.1.24 cpe:/a:php:php:7.1.24:rc1
Php Php 7.1.25 cpe:/a:php:php:7.1.25
Php Php 7.1.25 cpe:/a:php:php:7.1.25:-
Php Php 7.1.25 cpe:/a:php:php:7.1.25:rc1
Php Php 7.1.26 cpe:/a:php:php:7.1.26
Php Php 7.1.27 cpe:/a:php:php:7.1.27
Php Php 7.1.28 cpe:/a:php:php:7.1.28
Php Php 7.1.29 cpe:/a:php:php:7.1.29
Php Php 7.1.30 cpe:/a:php:php:7.1.30
Php Php 7.2.0 cpe:/a:php:php:7.2.0
Php Php 7.2.0 cpe:/a:php:php:7.2.0:-
Php Php 7.2.0 cpe:/a:php:php:7.2.0:alpha1
Php Php 7.2.0 cpe:/a:php:php:7.2.0:alpha2
Php Php 7.2.0 cpe:/a:php:php:7.2.0:alpha3
Php Php 7.2.0 cpe:/a:php:php:7.2.0:beta1
Php Php 7.2.0 cpe:/a:php:php:7.2.0:beta2
Php Php 7.2.0 cpe:/a:php:php:7.2.0:beta3
Php Php 7.2.0 cpe:/a:php:php:7.2.0:rc1
Php Php 7.2.0 cpe:/a:php:php:7.2.0:rc2
Php Php 7.2.0 cpe:/a:php:php:7.2.0:rc3
Php Php 7.2.0 cpe:/a:php:php:7.2.0:rc4
Php Php 7.2.0 cpe:/a:php:php:7.2.0:rc5
Php Php 7.2.0 cpe:/a:php:php:7.2.0:rc6
Php Php 7.2.1 cpe:/a:php:php:7.2.1
Php Php 7.2.1 cpe:/a:php:php:7.2.1:-
Php Php 7.2.1 cpe:/a:php:php:7.2.1:rc1
Php Php 7.2.2 cpe:/a:php:php:7.2.2
Php Php 7.2.2 cpe:/a:php:php:7.2.2:-
Php Php 7.2.2 cpe:/a:php:php:7.2.2:rc1
Php Php 7.2.3 cpe:/a:php:php:7.2.3
Php Php 7.2.3 cpe:/a:php:php:7.2.3:-
Php Php 7.2.3 cpe:/a:php:php:7.2.3:rc1
Php Php 7.2.4 cpe:/a:php:php:7.2.4
Php Php 7.2.4 cpe:/a:php:php:7.2.4:-
Php Php 7.2.4 cpe:/a:php:php:7.2.4:rc1
Php Php 7.2.5 cpe:/a:php:php:7.2.5
Php Php 7.2.5 cpe:/a:php:php:7.2.5:-
Php Php 7.2.5 cpe:/a:php:php:7.2.5:rc1
Php Php 7.2.6 cpe:/a:php:php:7.2.6
Php Php 7.2.6 cpe:/a:php:php:7.2.6:-
Php Php 7.2.6 cpe:/a:php:php:7.2.6:rc1
Php Php 7.2.7 cpe:/a:php:php:7.2.7
Php Php 7.2.7 cpe:/a:php:php:7.2.7:-
Php Php 7.2.7 cpe:/a:php:php:7.2.7:rc1
Php Php 7.2.8 cpe:/a:php:php:7.2.8
Php Php 7.2.8 cpe:/a:php:php:7.2.8:-
Php Php 7.2.8 cpe:/a:php:php:7.2.8:rc1
Php Php 7.2.9 cpe:/a:php:php:7.2.9
Php Php 7.2.9 cpe:/a:php:php:7.2.9:-
Php Php 7.2.9 cpe:/a:php:php:7.2.9:rc1
Php Php 7.2.10 cpe:/a:php:php:7.2.10
Php Php 7.2.10 cpe:/a:php:php:7.2.10:-
Php Php 7.2.10 cpe:/a:php:php:7.2.10:rc1
Php Php 7.2.11 cpe:/a:php:php:7.2.11
Php Php 7.2.11 cpe:/a:php:php:7.2.11:-
Php Php 7.2.11 cpe:/a:php:php:7.2.11:rc1
Php Php 7.2.12 cpe:/a:php:php:7.2.12
Php Php 7.2.12 cpe:/a:php:php:7.2.12:-
Php Php 7.2.12 cpe:/a:php:php:7.2.12:rc1
Php Php 7.2.13 cpe:/a:php:php:7.2.13
Php Php 7.2.13 cpe:/a:php:php:7.2.13:-
Php Php 7.2.13 cpe:/a:php:php:7.2.13:rc1
Php Php 7.2.14 cpe:/a:php:php:7.2.14
Php Php 7.2.14 cpe:/a:php:php:7.2.14:-
Php Php 7.2.14 cpe:/a:php:php:7.2.14:rc1
Php Php 7.2.15 cpe:/a:php:php:7.2.15
Php Php 7.2.16 cpe:/a:php:php:7.2.16
Php Php 7.2.17 cpe:/a:php:php:7.2.17
Php Php 7.2.18 cpe:/a:php:php:7.2.18
Php Php 7.2.19 cpe:/a:php:php:7.2.19
Php Php 7.3.0 cpe:/a:php:php:7.3.0
Php Php 7.3.0 cpe:/a:php:php:7.3.0:-
Php Php 7.3.0 cpe:/a:php:php:7.3.0:alpha1
Php Php 7.3.0 cpe:/a:php:php:7.3.0:alpha2
Php Php 7.3.0 cpe:/a:php:php:7.3.0:alpha3
Php Php 7.3.0 cpe:/a:php:php:7.3.0:alpha4
Php Php 7.3.0 cpe:/a:php:php:7.3.0:beta1
Php Php 7.3.0 cpe:/a:php:php:7.3.0:beta2
Php Php 7.3.0 cpe:/a:php:php:7.3.0:beta3
Php Php 7.3.0 cpe:/a:php:php:7.3.0:rc1
Php Php 7.3.0 cpe:/a:php:php:7.3.0:rc2
Php Php 7.3.0 cpe:/a:php:php:7.3.0:rc3
Php Php 7.3.0 cpe:/a:php:php:7.3.0:rc4
Php Php 7.3.0 cpe:/a:php:php:7.3.0:rc5
Php Php 7.3.0 cpe:/a:php:php:7.3.0:rc6
Php Php 7.3.1 cpe:/a:php:php:7.3.1
Php Php 7.3.1 cpe:/a:php:php:7.3.1:-
Php Php 7.3.1 cpe:/a:php:php:7.3.1:rc1
Php Php 7.3.2 cpe:/a:php:php:7.3.2
Php Php 7.3.2 cpe:/a:php:php:7.3.2:-
Php Php 7.3.2 cpe:/a:php:php:7.3.2:rc1
Php Php 7.3.3 cpe:/a:php:php:7.3.3
Php Php 7.3.3 cpe:/a:php:php:7.3.3:-
Php Php 7.3.3 cpe:/a:php:php:7.3.3:rc1
Php Php 7.3.4 cpe:/a:php:php:7.3.4
Php Php 7.3.5 cpe:/a:php:php:7.3.5
Php Php 7.3.6 cpe:/a:php:php:7.3.6
Canonical Ubuntu Linux 12.04 cpe:/o:canonical:ubuntu_linux:12.04::~~esm~~~
Canonical Ubuntu Linux 14.04 cpe:/o:canonical:ubuntu_linux:14.04::~~esm~~~
Canonical Ubuntu Linux 16.04 cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~
Canonical Ubuntu Linux 18.04 cpe:/o:canonical:ubuntu_linux:18.04::~~lts~~~
Canonical Ubuntu Linux 19.04 cpe:/o:canonical:ubuntu_linux:19.04
Debian Debian Linux 8.0 cpe:/o:debian:debian_linux:8.0
  1. Php (1) Search CVE
    1. Php (58) Search CVE
      1. 7.1.0
      2. 7.1.1
      3. 7.1.2
      4. 7.1.3
      5. 7.1.4
      6. 7.1.5
      7. 7.1.6
      8. 7.1.7
      9. 7.1.8
      10. 7.1.9
      11. 7.1.10
      12. 7.1.11
      13. 7.1.12
      14. 7.1.13
      15. 7.1.14
      16. 7.1.15
      17. 7.1.16
      18. 7.1.17
      19. 7.1.18
      20. 7.1.19
      21. 7.1.20
      22. 7.1.21
      23. 7.1.22
      24. 7.1.23
      25. 7.1.24
      26. 7.1.25
      27. 7.1.26
      28. 7.1.27
      29. 7.1.28
      30. 7.1.29
      31. 7.1.30
      32. 7.2.0
      33. 7.2.1
      34. 7.2.2
      35. 7.2.3
      36. 7.2.4
      37. 7.2.5
      38. 7.2.6
      39. 7.2.7
      40. 7.2.8
      41. 7.2.9
      42. 7.2.10
      43. 7.2.11
      44. 7.2.12
      45. 7.2.13
      46. 7.2.14
      47. 7.2.15
      48. 7.2.16
      49. 7.2.17
      50. 7.2.18
      51. 7.2.19
      52. 7.3.0
      53. 7.3.1
      54. 7.3.2
      55. 7.3.3
      56. 7.3.4
      57. 7.3.5
      58. 7.3.6
  2. Canonical (1) Search CVE
    1. Ubuntu Linux (5) Search CVE
      1. 12.04
      2. 14.04
      3. 16.04
      4. 18.04
      5. 19.04
  3. Debian (1) Search CVE
    1. Debian Linux (1) Search CVE
      1. 8.0

CWE

ID Name Description Links
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer The software performs operations on a memory buffer, but it can read from or write to a memory location that is outside of the intended boundary of the buffer. CVE

History of changes

Date Event
2019-08-22 07:15
2019-08-16 14:33
2019-08-09 20:15

New CVE