CVE-2019-1257

A remote code execution vulnerability exists in Microsoft SharePoint when the software fails to check the source markup of an application package, aka 'Microsoft SharePoint Remote Code Execution Vulnerability'. This CVE ID is unique from CVE-2019-1295, CVE-2019-1296.

Published : 2019-09-11 22:15 Updated : 2019-09-12 14:24

6.5
CVSS Score More info
Score 6.5 / 10
6.5
Vendor Product Version URI
Microsoft Sharepoint Enterprise Server 2016 cpe:/a:microsoft:sharepoint_enterprise_server:2016
Microsoft Sharepoint Foundation 2010 cpe:/a:microsoft:sharepoint_foundation:2010:sp2
Microsoft Sharepoint Foundation 2013 cpe:/a:microsoft:sharepoint_foundation:2013:sp1
Microsoft Sharepoint Server 2019 cpe:/a:microsoft:sharepoint_server:2019
  1. Microsoft (3) Search CVE
    1. Sharepoint Enterprise Server (1) Search CVE
      1. 2016
    2. Sharepoint Server (1) Search CVE
      1. 2019
    3. Sharepoint Foundation (2) Search CVE
      1. 2010
      2. 2013

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2019-09-12 14:24
2019-09-11 23:34

New CVE