CVE-2019-17426

Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).

Published : 2019-10-10 02:05 Updated : 2019-10-16 13:34

6.4
CVSS Score More info
Score 6.4 / 10
6.4
Vendor Product Version URI
Mongoosejs Mongoose 5.7.4 cpe:/a:mongoosejs:mongoose:5.7.4::~~~node.js~~
  1. Mongoosejs (1) Search CVE
    1. Mongoose (1) Search CVE
      1. 5.7.4

CWE

ID Name Description Links
CWE-20 Improper Input Validation The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program. CVE

History of changes

Date Event
2019-10-16 13:34
2019-10-10 12:03

New CVE