CVE-2019-1808

A vulnerability in the Image Signature Verification feature of Cisco NX-OS Software could allow an authenticated, local attacker with administrator-level credentials to install a malicious software patch on an affected device. The vulnerability is due to improper verification of digital signatures for patch images. An attacker could exploit this vulnerability by loading an unsigned software patch on an affected device. A successful exploit could allow the attacker to boot a malicious software patch image.

Published : 2019-05-15 23:29 Updated : 2019-05-20 13:14

2.1
CVSS Score More info
Score 2.1 / 10
2.1
Vendor Product Version URI
Cisco Nx-os 7.2%280%29n1%280.1%29 cpe:/o:cisco:nx-os:7.2%280%29n1%280.1%29
Cisco Nx-os 7.2%280%29n1%281%29 cpe:/o:cisco:nx-os:7.2%280%29n1%281%29
Cisco Nx-os 7.2%280%29zz%2899.1%29 cpe:/o:cisco:nx-os:7.2%280%29zz%2899.1%29
Cisco Nx-os 7.2%280%29zz%2899.3%29 cpe:/o:cisco:nx-os:7.2%280%29zz%2899.3%29
Cisco Nx-os 7.2%281%29n1%281%29 cpe:/o:cisco:nx-os:7.2%281%29n1%281%29
Cisco Nx-os 7.3%280%29n1%281%29 cpe:/o:cisco:nx-os:7.3%280%29n1%281%29
Cisco Nx-os 7.3%280%29zn%280.9%29 cpe:/o:cisco:nx-os:7.3%280%29zn%280.9%29
Cisco Nx-os 7.3%280%29zn%280.81%29 cpe:/o:cisco:nx-os:7.3%280%29zn%280.81%29
Cisco Nx-os 7.3%280%29zn%280.83%29 cpe:/o:cisco:nx-os:7.3%280%29zn%280.83%29
Cisco Nx-os 7.3%282%29n1%280.296%29 cpe:/o:cisco:nx-os:7.3%282%29n1%280.296%29
Cisco Nx-os 7.3%282%29n1%280.395%29 cpe:/o:cisco:nx-os:7.3%282%29n1%280.395%29
Cisco Nx-os 8.0%281%29s2 cpe:/o:cisco:nx-os:8.0%281%29s2
Cisco Nx-os 8.1%280.2%29s0 cpe:/o:cisco:nx-os:8.1%280.2%29s0
Cisco Nx-os 8.1%280.59%29s0 cpe:/o:cisco:nx-os:8.1%280.59%29s0
Cisco Nx-os 8.1%280.112%29s0 cpe:/o:cisco:nx-os:8.1%280.112%29s0
Cisco Nx-os 8.1%281%29 cpe:/o:cisco:nx-os:8.1%281%29
Cisco Nx-os 8.1%281%29s5 cpe:/o:cisco:nx-os:8.1%281%29s5
Cisco Nx-os 8.3%280%29cv%280.342%29 cpe:/o:cisco:nx-os:8.3%280%29cv%280.342%29
Cisco Nx-os 8.3%280%29cv%280.345%29 cpe:/o:cisco:nx-os:8.3%280%29cv%280.345%29
  1. Cisco (1) Search CVE
    1. Nx-os (19) Search CVE
      1. 7.2%280%29n1%280.1%29
      2. 7.2%280%29n1%281%29
      3. 7.2%280%29zz%2899.1%29
      4. 7.2%280%29zz%2899.3%29
      5. 7.2%281%29n1%281%29
      6. 7.3%280%29n1%281%29
      7. 7.3%280%29zn%280.9%29
      8. 7.3%280%29zn%280.81%29
      9. 7.3%280%29zn%280.83%29
      10. 7.3%282%29n1%280.296%29
      11. 7.3%282%29n1%280.395%29
      12. 8.0%281%29s2
      13. 8.1%280.2%29s0
      14. 8.1%280.59%29s0
      15. 8.1%280.112%29s0
      16. 8.1%281%29
      17. 8.1%281%29s5
      18. 8.3%280%29cv%280.342%29
      19. 8.3%280%29cv%280.345%29

CWE

ID Name Description Links
CWE-347 Improper Verification of Cryptographic Signature The software does not verify, or incorrectly verifies, the cryptographic signature for data. CVE

History of changes

Date Event
2019-05-20 13:14
2019-05-17 12:29
2019-05-15 23:29

New CVE