CVE-2019-3813

Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

Published : 2019-02-04 18:29 Updated : 2019-03-08 18:42

5.4
CVSS Score More info
Score 5.4 / 10
5.4
Vendor Product Version URI
Spice Project Spice 0.5.2 cpe:/a:spice_project:spice:0.5.2
Spice Project Spice 0.5.3 cpe:/a:spice_project:spice:0.5.3
Spice Project Spice 0.6.0 cpe:/a:spice_project:spice:0.6.0
Spice Project Spice 0.6.1 cpe:/a:spice_project:spice:0.6.1
Spice Project Spice 0.6.2 cpe:/a:spice_project:spice:0.6.2
Spice Project Spice 0.6.3 cpe:/a:spice_project:spice:0.6.3
Spice Project Spice 0.6.4 cpe:/a:spice_project:spice:0.6.4
Spice Project Spice 0.7.0 cpe:/a:spice_project:spice:0.7.0
Spice Project Spice 0.7.1 cpe:/a:spice_project:spice:0.7.1
Spice Project Spice 0.7.2 cpe:/a:spice_project:spice:0.7.2
Spice Project Spice 0.7.3 cpe:/a:spice_project:spice:0.7.3
Spice Project Spice 0.8.0 cpe:/a:spice_project:spice:0.8.0
Spice Project Spice 0.8.1 cpe:/a:spice_project:spice:0.8.1
Spice Project Spice 0.8.2 cpe:/a:spice_project:spice:0.8.2
Spice Project Spice 0.8.3 cpe:/a:spice_project:spice:0.8.3
Spice Project Spice 0.9.0 cpe:/a:spice_project:spice:0.9.0
Spice Project Spice 0.9.1 cpe:/a:spice_project:spice:0.9.1
Spice Project Spice 0.10.0 cpe:/a:spice_project:spice:0.10.0
Spice Project Spice 0.10.1 cpe:/a:spice_project:spice:0.10.1
Spice Project Spice 0.11.0 cpe:/a:spice_project:spice:0.11.0
Spice Project Spice 0.11.3 cpe:/a:spice_project:spice:0.11.3
Spice Project Spice 0.12.0 cpe:/a:spice_project:spice:0.12.0
Spice Project Spice 0.12.2 cpe:/a:spice_project:spice:0.12.2
Spice Project Spice 0.12.3 cpe:/a:spice_project:spice:0.12.3
Spice Project Spice 0.12.4 cpe:/a:spice_project:spice:0.12.4
Canonical Ubuntu Linux 14.04 cpe:/o:canonical:ubuntu_linux:14.04::~~lts~~~
Canonical Ubuntu Linux 16.04 cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~
Canonical Ubuntu Linux 18.04 cpe:/o:canonical:ubuntu_linux:18.04::~~lts~~~
Canonical Ubuntu Linux 18.10 cpe:/o:canonical:ubuntu_linux:18.10
Debian Debian Linux 8.0 cpe:/o:debian:debian_linux:8.0
Debian Debian Linux 9.0 cpe:/o:debian:debian_linux:9.0
Redhat Enterprise Linux Desktop 6.0 cpe:/o:redhat:enterprise_linux_desktop:6.0
Redhat Enterprise Linux Desktop 7.0 cpe:/o:redhat:enterprise_linux_desktop:7.0
Redhat Enterprise Linux Server 6.0 cpe:/o:redhat:enterprise_linux_server:6.0
Redhat Enterprise Linux Server 7.0 cpe:/o:redhat:enterprise_linux_server:7.0
Redhat Enterprise Linux Server Aus 7.6 cpe:/o:redhat:enterprise_linux_server_aus:7.6
Redhat Enterprise Linux Server Eus 7.6 cpe:/o:redhat:enterprise_linux_server_eus:7.6
Redhat Enterprise Linux Server Tus 7.6 cpe:/o:redhat:enterprise_linux_server_tus:7.6
Redhat Enterprise Linux Workstation 6.0 cpe:/o:redhat:enterprise_linux_workstation:6.0
Redhat Enterprise Linux Workstation 7.0 cpe:/o:redhat:enterprise_linux_workstation:7.0
Redhat Virtualization 4.0 cpe:/o:redhat:virtualization:4.0
  1. Spice Project (1) Search CVE
    1. Spice (25) Search CVE
      1. 0.5.2
      2. 0.5.3
      3. 0.6.0
      4. 0.6.1
      5. 0.6.2
      6. 0.6.3
      7. 0.6.4
      8. 0.7.0
      9. 0.7.1
      10. 0.7.2
      11. 0.7.3
      12. 0.8.0
      13. 0.8.1
      14. 0.8.2
      15. 0.8.3
      16. 0.9.0
      17. 0.9.1
      18. 0.10.0
      19. 0.10.1
      20. 0.11.0
      21. 0.11.3
      22. 0.12.0
      23. 0.12.2
      24. 0.12.3
      25. 0.12.4
  2. Redhat (7) Search CVE
    1. Enterprise Linux Server Tus (1) Search CVE
      1. 7.6
    2. Virtualization (1) Search CVE
      1. 4.0
    3. Enterprise Linux Server Aus (1) Search CVE
      1. 7.6
    4. Enterprise Linux Server (2) Search CVE
      1. 6.0
      2. 7.0
    5. Enterprise Linux Desktop (2) Search CVE
      1. 6.0
      2. 7.0
    6. Enterprise Linux Server Eus (1) Search CVE
      1. 7.6
    7. Enterprise Linux Workstation (2) Search CVE
      1. 6.0
      2. 7.0
  3. Canonical (1) Search CVE
    1. Ubuntu Linux (4) Search CVE
      1. 14.04
      2. 16.04
      3. 18.04
      4. 18.10
  4. Debian (1) Search CVE
    1. Debian Linux (2) Search CVE
      1. 8.0
      2. 9.0

CWE

ID Name Description Links
CWE-125 Out-of-bounds Read The software reads data past the end, or before the beginning, of the intended buffer. CVE

History of changes

Date Event
2019-03-08 18:42
2019-03-06 11:29
2019-02-05 14:56
2019-02-05 11:29
2019-02-04 18:29

New CVE