CVE-2019-9512

Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service. The attacker sends continual pings to an HTTP/2 peer, causing the peer to build an internal queue of responses. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

Published : 2019-08-13 21:15 Updated : 2019-08-23 21:15

7.8
CVSS Score More info
Score 7.8 / 10
7.8
Vendor Product Version URI
Apache Traffic Server 6.0.0 cpe:/a:apache:traffic_server:6.0.0
Apache Traffic Server 6.0.3 cpe:/a:apache:traffic_server:6.0.3
Apache Traffic Server 6.1.0 cpe:/a:apache:traffic_server:6.1.0
Apache Traffic Server 6.1.1 cpe:/a:apache:traffic_server:6.1.1
Apache Traffic Server 6.2.0 cpe:/a:apache:traffic_server:6.2.0
Apache Traffic Server 6.2.1 cpe:/a:apache:traffic_server:6.2.1
Apache Traffic Server 6.2.1 cpe:/a:apache:traffic_server:6.2.1:rc0
Apache Traffic Server 6.2.2 cpe:/a:apache:traffic_server:6.2.2
Apache Traffic Server 6.2.2 cpe:/a:apache:traffic_server:6.2.2:rc0
Apache Traffic Server 6.2.3 cpe:/a:apache:traffic_server:6.2.3
Apache Traffic Server 7.0.0 cpe:/a:apache:traffic_server:7.0.0
Apache Traffic Server 7.0.0 cpe:/a:apache:traffic_server:7.0.0:rc0
Apache Traffic Server 7.0.0 cpe:/a:apache:traffic_server:7.0.0:rc1
Apache Traffic Server 7.0.0 cpe:/a:apache:traffic_server:7.0.0:rc2
Apache Traffic Server 7.1.0 cpe:/a:apache:traffic_server:7.1.0
Apache Traffic Server 7.1.0 cpe:/a:apache:traffic_server:7.1.0:rc0
Apache Traffic Server 7.1.0 cpe:/a:apache:traffic_server:7.1.0:rc1
Apache Traffic Server 7.1.1 cpe:/a:apache:traffic_server:7.1.1
Apache Traffic Server 7.1.1 cpe:/a:apache:traffic_server:7.1.1:rc0
Apache Traffic Server 7.1.1 cpe:/a:apache:traffic_server:7.1.1:rc1
Apache Traffic Server 7.1.2 cpe:/a:apache:traffic_server:7.1.2
Apache Traffic Server 7.1.2 cpe:/a:apache:traffic_server:7.1.2:rc0
Apache Traffic Server 7.1.2 cpe:/a:apache:traffic_server:7.1.2:rc1
Apache Traffic Server 7.1.2 cpe:/a:apache:traffic_server:7.1.2:rc2
Apache Traffic Server 7.1.2 cpe:/a:apache:traffic_server:7.1.2:rc3
Apache Traffic Server 7.1.2 cpe:/a:apache:traffic_server:7.1.2:rc4
Apache Traffic Server 7.1.3 cpe:/a:apache:traffic_server:7.1.3
Apache Traffic Server 7.1.3 cpe:/a:apache:traffic_server:7.1.3:rc0
Apache Traffic Server 7.1.4 cpe:/a:apache:traffic_server:7.1.4
Apache Traffic Server 7.1.4 cpe:/a:apache:traffic_server:7.1.4:rc0
Apache Traffic Server 7.1.4 cpe:/a:apache:traffic_server:7.1.4:rc1
Apache Traffic Server 7.1.5 cpe:/a:apache:traffic_server:7.1.5
Apache Traffic Server 8.0.0 cpe:/a:apache:traffic_server:8.0.0
Apache Traffic Server 8.0.0 cpe:/a:apache:traffic_server:8.0.0:rc0
Apache Traffic Server 8.0.0 cpe:/a:apache:traffic_server:8.0.0:rc1
Apache Traffic Server 8.0.0 cpe:/a:apache:traffic_server:8.0.0:rc2
Apache Traffic Server 8.0.0 cpe:/a:apache:traffic_server:8.0.0:rc3
Apache Traffic Server 8.0.0 cpe:/a:apache:traffic_server:8.0.0:rc4
Apache Traffic Server 8.0.1 cpe:/a:apache:traffic_server:8.0.1
Apache Traffic Server 8.0.2 cpe:/a:apache:traffic_server:8.0.2
Apache Traffic Server 8.0.3 cpe:/a:apache:traffic_server:8.0.3
Apple Swiftnio 1.0.0 cpe:/a:apple:swiftnio:1.0.0
Apple Swiftnio 1.0.1 cpe:/a:apple:swiftnio:1.0.1
Apple Swiftnio 1.1.0 cpe:/a:apple:swiftnio:1.1.0
Apple Swiftnio 1.1.1 cpe:/a:apple:swiftnio:1.1.1
Apple Swiftnio 1.2.0 cpe:/a:apple:swiftnio:1.2.0
Apple Swiftnio 1.2.1 cpe:/a:apple:swiftnio:1.2.1
Apple Swiftnio 1.2.2 cpe:/a:apple:swiftnio:1.2.2
Apple Swiftnio 1.3.0 cpe:/a:apple:swiftnio:1.3.0
Apple Swiftnio 1.3.1 cpe:/a:apple:swiftnio:1.3.1
Apple Swiftnio 1.3.2 cpe:/a:apple:swiftnio:1.3.2
Apple Swiftnio 1.4.0 cpe:/a:apple:swiftnio:1.4.0
Debian Debian Linux 10.0 cpe:/o:debian:debian_linux:10.0
  1. Debian (1) Search CVE
    1. Debian Linux (1) Search CVE
      1. 10.0
  2. Apple (1) Search CVE
    1. Swiftnio (11) Search CVE
      1. 1.0.0
      2. 1.0.1
      3. 1.1.0
      4. 1.1.1
      5. 1.2.0
      6. 1.2.1
      7. 1.2.2
      8. 1.3.0
      9. 1.3.1
      10. 1.3.2
      11. 1.4.0
  3. Apache (1) Search CVE
    1. Traffic Server (19) Search CVE
      1. 6.0.0
      2. 6.0.3
      3. 6.1.0
      4. 6.1.1
      5. 6.2.0
      6. 6.2.1
      7. 6.2.2
      8. 6.2.3
      9. 7.0.0
      10. 7.1.0
      11. 7.1.1
      12. 7.1.2
      13. 7.1.3
      14. 7.1.4
      15. 7.1.5
      16. 8.0.0
      17. 8.0.1
      18. 8.0.2
      19. 8.0.3

CWE

ID Name Description Links
CWE-400 Uncontrolled Resource Consumption ('Resource Exhaustion') The software does not properly restrict the size or amount of resources that are requested or influenced by an actor, which can be used to consume more resources than intended. CVE

History of changes

Date Event
2019-08-23 21:15
2019-08-23 13:47
2019-08-14 11:19
2019-08-13 21:15

New CVE