Vulnerabilities (CVE)

Vendor filter

Spice Project Subscribe

Product filter

Spice Subscribe

Filter

10 total CVE
CVE Vendors Products Updated CVSS
CVE-2018-10873 4 Spice Project, Redhat, Canonical and 1 more 11 Spice, Virtualization, Virtualization Host and 8 more 2019-10-09 6.5
A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to...
CVE-2016-9578 3 Spice Project, Debian, Redhat 7 Spice, Debian Linux, Enterprise Linux Desktop and 4 more 2019-10-09 5.0
A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An attacker able to connect to the SPICE server could send crafted messages which would cause the process to crash.
CVE-2016-9577 3 Spice Project, Debian, Redhat 7 Spice, Debian Linux, Enterprise Linux Desktop and 4 more 2019-10-09 6.5
A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.
CVE-2018-10893 1 Spice Project 1 Spice 2019-08-06 6.5
Multiple integer overflow and buffer overflow issues were discovered in spice-client's handling of LZ compressed frames. A malicious server could cause the client to crash or, potentially, execute arbitrary code.
CVE-2013-4282 2 Spice Project, Redhat 3 Enterprise Virtualization, Enterprise Linux, Spice 2019-04-22 5.0
Stack-based buffer overflow in the reds_handle_ticket function in server/reds.c in SPICE 0.12.0 allows remote attackers to cause a denial of service (crash) via a long password in a SPICE ticket.
CVE-2015-3247 2 Spice Project, Redhat 6 Enterprise Linux Desktop, Enterprise Linux, Spice and 3 more 2019-04-22 6.9
Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host...
CVE-2019-3813 4 Spice Project, Canonical, Debian and 1 more 10 Spice, Ubuntu Linux, Debian Linux and 7 more 2019-03-08 5.4
Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.
CVE-2017-7506 1 Spice Project 1 Spice 2018-11-08 6.5
spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into crash and/or server memory leak.
CVE-2015-5260 4 Debian, Spice Project, Canonical and 1 more 9 Ubuntu Linux, Debian Linux, Enterprise Linux Desktop and 6 more 2017-09-16 7.2
Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via QXL commands related to the surface_id parameter.
CVE-2013-4130 2 Spice Project, Canonical 2 Ubuntu Linux, Spice 2014-01-24 5.0
The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable...