Vulnerabilities (CVE)

Vendor filter

Pulpproject Subscribe

Product filter

Pulp Subscribe

Filter

13 total CVE
CVE Vendors Products Updated CVSS
CVE-2018-1090 3 Pulpproject, Redhat, Fedoraproject 3 Pulp, Satellite, Fedora 2019-10-09 5.0
In Pulp before version 2.16.2, secrets are passed into override_config when triggering a task and then become readable to all users with read access on the distributor/importer. An attacker with API access can then view these secrets.
CVE-2018-10917 1 Pulpproject 1 Pulp 2019-10-03 4.0
pulp 2.16.x and possibly older is vulnerable to an improper path parsing. A malicious user or a malicious iso feed repository can write to locations accessible to the 'apache' user. This may lead to overwrite of published content on other iso...
CVE-2016-3704 2 Fedoraproject, Pulpproject 2 Fedora, Pulp 2018-02-23 5.0
Pulp before 2.8.5 uses bash's $RANDOM in an unsafe way to generate passwords.
CVE-2016-3696 2 Fedoraproject, Pulpproject 2 Fedora, Pulp 2018-02-23 2.1
The pulp-qpid-ssl-cfg script in Pulp before 2.8.5 allows local users to obtain the CA key.
CVE-2016-3112 1 Pulpproject 1 Pulp 2018-01-05 5.0
client/consumer/cli.py in Pulp before 2.8.3 writes consumer private keys to etc/pki/pulp/consumer/consumer-cert.pem as world-readable, which allows remote authenticated users to obtain the consumer private keys and escalate privileges by reading...
CVE-2016-3111 1 Pulpproject 1 Pulp 2018-01-05 2.1
pulp.spec in the installation process for Pulp 2.8.3 generates the RSA key pairs used to validate messages between the pulp server and pulp consumers in a directory that is world-readable before later modifying the permissions, which might allow...
CVE-2016-3108 1 Pulpproject 1 Pulp 2018-01-05 3.6
The pulp-gen-nodes-certificate script in Pulp before 2.8.3 allows local users to leak the keys or write to arbitrary files via a symlink attack.
CVE-2016-3107 1 Pulpproject 1 Pulp 2018-01-05 2.1
The Node certificate in Pulp before 2.8.3 contains the private key, and is stored in a world-readable file in the "/etc/pki/pulp/nodes/" directory, which allows local users to gain access to sensitive data.
CVE-2015-5164 1 Pulpproject 1 Qpid 2017-11-08 9.0
The Qpid server on Red Hat Satellite 6 does not properly restrict message types, which allows remote authenticated users with administrative access on a managed content host to execute arbitrary code via a crafted message, related to a pickle...
CVE-2015-5263 1 Pulpproject 1 Pulp 2017-10-05 6.8
pulp-consumer-client 2.4.0 through 2.6.3 does not check the server's TLS certificate signatures when retrieving the server's public key upon registration.
CVE-2016-3095 2 Pulpproject, Fedoraproject 2 Pulp, Fedora 2017-06-15 2.1
server/bin/pulp-gen-ca-certificate in Pulp before 2.8.2 allows local users to read the generated private key.
CVE-2016-3106 1 Pulpproject 1 Pulp 2017-04-26 5.0
Pulp before 2.8.3 creates a temporary directory during CA key generation in an insecure manner.
CVE-2013-7450 1 Pulpproject 1 Pulp 2017-04-26 5.0
Pulp before 2.3.0 uses the same the same certificate authority key and certificate for all installations.