Vulnerabilities (CVE)

Vendor filter

Nlnetlabs Subscribe

Product filter

Unbound Subscribe

Filter

7 total CVE
CVE Vendors Products Updated CVSS
CVE-2019-16866 2 Nlnetlabs, Canonical 2 Unbound, Ubuntu Linux 2019-10-16 5.0
Unbound before 1.9.4 accesses uninitialized memory, which allows remote attackers to trigger a crash via a crafted NOTIFY query. The source IP address of the query must match an access-control rule.
CVE-2017-15105 3 Nlnetlabs, Debian, Canonical 3 Unbound, Debian Linux, Ubuntu Linux 2019-10-09 5.0
A flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence (NXDOMAIN answer) of an existing wildcard record, or trick unbound...
CVE-2011-1922 1 Nlnetlabs 1 Unbound 2017-08-17 4.3
daemon/worker.c in Unbound 1.x before 1.4.10, when debugging functionality and the interface-automatic option are enabled, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted DNS request that...
CVE-2009-3602 1 Nlnetlabs 1 Unbound 2017-08-17 7.5
Unbound before 1.3.4 does not properly verify signatures for NSEC3 records, which allows remote attackers to cause secure delegations to be downgraded via DNS spoofing or other DNS-related attacks in conjunction with crafted delegation responses.
CVE-2014-8602 3 Debian, Nlnetlabs, Canonical 3 Unbound, Ubuntu Linux, Debian Linux 2016-11-28 4.3
iterator.c in NLnet Labs Unbound before 1.5.1 does not limit delegation chaining, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a large or infinite number of referrals.
CVE-2009-4008 1 Nlnetlabs 1 Unbound 2011-06-14 5.0
Unbound before 1.4.4 does not send responses for signed zones after mishandling an unspecified query, which allows remote attackers to cause a denial of service (DNSSEC outage) via a crafted query.
CVE-2010-0969 1 Nlnetlabs 1 Unbound 2011-06-02 5.0
Unbound before 1.4.3 does not properly align structures on 64-bit platforms, which allows remote attackers to cause a denial of service (daemon crash) via unspecified vectors.