Vulnerabilities (CVE)

Vendor filter

Mozilla Subscribe

Product filter

Thunderbird Subscribe

Filter

942 total CVE
CVE Vendors Products Updated CVSS
CVE-2015-4000 12 Google, Openssl, Apple and 9 more 25 Safari, Network Security Services, Ie and 22 more 2019-10-09 4.3
The TLS protocol 1.2 and earlier, when a DHE_EXPORT ciphersuite is enabled on a server but not on a client, does not properly convey a DHE_EXPORT choice, which allows man-in-the-middle attackers to conduct cipher-downgrade attacks by rewriting a...
CVE-2007-4841 1 Mozilla 3 Firefox, Thunderbird, Seamonkey 2019-10-09 9.3
Mozilla Firefox before 2.0.0.8, Thunderbird before 2.0.0.8, and SeaMonkey before 1.1.5 allows remote attackers to execute arbitrary commands via a (1) mailto, (2) nntp, (3) news, or (4) snews URI with invalid "%" encoding, related to improper...
CVE-2007-0777 2 Mozilla, Canonical 4 Firefox, Seamonkey, Thunderbird and 1 more 2019-10-09 9.3
The JavaScript engine in Mozilla Firefox before 1.5.0.10 and 2.x before 2.0.0.2, Thunderbird before 1.5.0.10, and SeaMonkey before 1.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via certain...
CVE-2007-0009 3 Mozilla, Canonical, Debian 6 Firefox, Seamonkey, Thunderbird and 3 more 2019-10-09 6.8
Stack-based buffer overflow in the SSLv2 support in Mozilla Network Security Services (NSS) before 3.11.5, as used by Firefox before 1.5.0.10 and 2.x before 2.0.0.2, Thunderbird before 1.5.0.10, SeaMonkey before 1.0.8, and certain Sun Java System...
CVE-2006-6500 3 Mozilla, Canonical, Debian 5 Firefox, Seamonkey, Thunderbird and 2 more 2019-10-09 6.8
Heap-based buffer overflow in Mozilla Firefox 2.x before 2.0.0.1, 1.5.x before 1.5.0.9, Thunderbird before 1.5.0.9, and SeaMonkey before 1.0.7 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code by...
CVE-2006-6499 3 Mozilla, Canonical, Debian 5 Firefox, Seamonkey, Thunderbird and 2 more 2019-10-09 4.3
The js_dtoa function in Mozilla Firefox 2.x before 2.0.0.1, 1.5.x before 1.5.0.9, Thunderbird before 1.5.0.9, and SeaMonkey before 1.0.7 overwrites memory instead of exiting when the floating point precision is reduced, which allows remote...
CVE-2019-11755 1 Mozilla 1 Thunderbird 2019-10-04 5.0
A crafted S/MIME message consisting of an inner encryption layer and an outer SignedData layer was shown as having a valid digital signature, although the signer might have had no access to the contents of the encrypted message, and might have...
CVE-2019-11752 1 Mozilla 3 Firefox, Firefox Esr, Thunderbird 2019-10-04 9.3
It is possible to delete an IndexedDB key value and subsequently try to extract it during conversion. This results in a use-after-free and a potentially exploitable crash. This vulnerability affects Firefox < 69, Thunderbird < 68.1, Thunderbird <...
CVE-2019-11746 1 Mozilla 3 Firefox, Firefox Esr, Thunderbird 2019-10-04 6.8
A use-after-free vulnerability can occur while manipulating video elements if the body is freed while still in use. This results in a potentially exploitable crash. This vulnerability affects Firefox < 69, Thunderbird < 68.1, Thunderbird < 60.9,...
CVE-2019-11744 1 Mozilla 3 Firefox, Firefox Esr, Thunderbird 2019-10-04 4.3
Some HTML elements, such as &lt;title&gt; and &lt;textarea&gt;, can contain literal angle brackets without treating them as markup. It is possible to pass a literal closing tag to .innerHTML on these elements, and subsequent content after that...
CVE-2019-11743 1 Mozilla 3 Firefox, Firefox Esr, Thunderbird 2019-10-04 4.3
Navigation events were not fully adhering to the W3C's "Navigation-Timing Level 2" draft specification in some instances for the unload event, which restricts access to detailed timing attributes to only be same-origin. This resulted in potential...
CVE-2019-11742 1 Mozilla 3 Firefox, Firefox Esr, Thunderbird 2019-10-04 4.3
A same-origin policy violation occurs allowing the theft of cross-origin images through a combination of SVG filters and a &lt;canvas&gt; element due to an error in how same-origin policy is applied to cached image content. The resulting...
CVE-2019-11740 1 Mozilla 3 Firefox, Firefox Esr, Thunderbird 2019-10-04 7.5
Mozilla developers and community members reported memory safety bugs present in Firefox 68, Firefox ESR 68, and Firefox 60.8. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could...
CVE-2019-11739 1 Mozilla 1 Thunderbird 2019-10-04 4.3
Encrypted S/MIME parts in a crafted multipart/alternative message can leak plaintext when included in a a HTML reply/forward. This vulnerability affects Thunderbird < 68.1 and Thunderbird < 60.9.
CVE-2017-5419 1 Mozilla 2 Firefox, Thunderbird 2019-10-03 7.8
If a malicious site repeatedly triggers a modal authentication prompt, eventually the browser UI will become non-responsive, requiring shutdown through the operating system. This is a denial of service (DOS) attack. This vulnerability affects...
CVE-2017-7803 3 Mozilla, Debian, Redhat 9 Firefox, Firefox Esr, Thunderbird and 6 more 2019-10-03 5.0
When a page's content security policy (CSP) header contains a "sandbox" directive, other directives are ignored. This results in the incorrect enforcement of CSP. This vulnerability affects Thunderbird < 52.3, Firefox ESR < 52.3, and Firefox < 55.
CVE-2017-7830 3 Mozilla, Debian, Redhat 9 Firefox, Firefox Esr, Thunderbird and 6 more 2019-10-03 4.3
The Resource Timing API incorrectly revealed navigations in cross-origin iframes. This is a same-origin policy violation and could allow for data theft of URLs loaded by users. This vulnerability affects Firefox < 57, Firefox ESR < 52.5, and...
CVE-2018-18505 4 Mozilla, Canonical, Debian and 1 more 11 Firefox, Firefox Esr, Thunderbird and 8 more 2019-10-03 7.5
An earlier fix for an Inter-process Communication (IPC) vulnerability, CVE-2011-3079, added authentication to communication between IPC endpoints and server parents during IPC process creation. This authentication is insufficient for channels...
CVE-2018-12374 4 Mozilla, Canonical, Debian and 1 more 7 Thunderbird, Ubuntu Linux, Debian Linux and 4 more 2019-10-03 4.3
Plaintext of decrypted emails can leak through by user submitting an embedded form by pressing enter key within a text input field. This vulnerability affects Thunderbird < 52.9.
CVE-2018-12392 4 Mozilla, Canonical, Debian and 1 more 11 Firefox, Firefox Esr, Thunderbird and 8 more 2019-10-03 7.5
When manipulating user events in nested loops while opening a document through script, it is possible to trigger a potentially exploitable crash due to poor event handling. This vulnerability affects Firefox < 63, Firefox ESR < 60.3, and...